Details

    • Type: Bug
    • Status: Closed
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: 2.1.6, 2.2.3, 2.3
    • Fix Version/s: 2.1.7, 2.2.4
    • Component/s: Course
    • Labels:
    • Testing Instructions:

      Do this for every course format that lets you edit section names.

      1. Create a course in Topics format
      2. Turn editing on.
      3. Edit the introduction to one section, and try to set the name to '0'.
      4. Save changes.
      5. Make sure that the section appears with name '0'.

      Show
      Do this for every course format that lets you edit section names. 1. Create a course in Topics format 2. Turn editing on. 3. Edit the introduction to one section, and try to set the name to '0'. 4. Save changes. 5. Make sure that the section appears with name '0'.
    • Affected Branches:
      MOODLE_21_STABLE, MOODLE_22_STABLE, MOODLE_23_STABLE
    • Fixed Branches:
      MOODLE_21_STABLE, MOODLE_22_STABLE
    • Pull from Repository:
    • Pull Master Branch:

      Description

      1. Create a course in Topics format
      2. Turn editing on.
      3. Edit the introduction to one section, and try to set the name to '0'.
      4. Save changes. You are ignored.

      (If you look in the DB, you can see the new name has been saved, but because of various if !empty checks, it is not used.

        Gliffy Diagrams

          Issue Links

            Activity

            stronk7 Eloy Lafuente (stronk7) added a comment -

            Integrated, thanks!

            stronk7 Eloy Lafuente (stronk7) added a comment -

            Passing, tested under 21_STABLE and master, weeks and topics formats.

            stronk7 Eloy Lafuente (stronk7) added a comment -

            Big thanks for the effort. This is now part of Moodle upstream. Let's wait for regressions, yay! LOL

            Ciao


              People

              • Assignee:
                timhunt Tim Hunt
                Reporter:
                timhunt Tim Hunt
                Integrator:
                Eloy Lafuente (stronk7)
                Tester:
                Eloy Lafuente (stronk7)
                Participants:
              • Votes:
                0 Vote for this issue
                Watchers:
                0 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:
                  Fix Release Date:
                  9/Jul/12