Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-33729

Activity Chooser doesn't listen to [x] button and doesn't cancel some listeners sufficiently

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: 2.3
    • Fix Version/s: 2.3
    • Component/s: Course, JavaScript
    • Labels:
    • Testing Instructions:

      Regression testing:

      • Open a course
      • Turn editing on
      • Open the module chooser
      • Press the [x] button in it's top-right corner
      • Re-open the module chooser
      • Confirm that all other functionality works:
        • Pressing escape closes correctly
        • Pressing cancel closes correctly
        • Selecting an activity updates it's description
        • Selecting an activity and using the 'Add' button opens the correct page
        • Double-clicking an activity opens the correct page

      If you want extra brownie points, also apply the patch for MDL-33649 and:

      • Open a course
      • Turn editing on
      • Refresh the page (in case you already had editing on on a course page - we need to make sure we're testing on a clean slate)
        • Confirm that you can scroll the page up/down*
      • Open the activity chooser
        • Confirm that you can't scroll the page background*
      • Hit the [x] button
        • Confirm that you can scroll the page up/down*
      Show
      Regression testing: Open a course Turn editing on Open the module chooser Press the [x] button in it's top-right corner Re-open the module chooser Confirm that all other functionality works: Pressing escape closes correctly Pressing cancel closes correctly Selecting an activity updates it's description Selecting an activity and using the 'Add' button opens the correct page Double-clicking an activity opens the correct page If you want extra brownie points, also apply the patch for MDL-33649 and: Open a course Turn editing on Refresh the page (in case you already had editing on on a course page - we need to make sure we're testing on a clean slate) Confirm that you can scroll the page up/down * Open the activity chooser Confirm that you can't scroll the page background * Hit the [x] button Confirm that you can scroll the page up/down *
    • Affected Branches:
      MOODLE_23_STABLE
    • Fixed Branches:
      MOODLE_23_STABLE
    • Pull from Repository:
    • Pull Master Branch:
      MDL-33729-master-1

      Description

      Ankit found a bug in MDL-33649 whereby use of the [x] button wasn't triggering the cancel_popup() function call.
      The cancel_popup event ensures that all of the event listeners are cancelled to prevent duplicate event handles so it's important that this be added really.

        Gliffy Diagrams

          Issue Links

            Activity

            dobedobedoh Andrew Nicols added a comment -

            Improved title since this patch also handles cancellation of some of the listeners which it was failing to do before.

            ankit_frenz Ankit Agarwal added a comment -

            Hi Andrew,
            This looks good.

            Feel free to submit for integration.

            Thanks

            nebgor Aparup Banerjee added a comment -

            thanks, integrated into master.

            fred Frédéric Massart added a comment - - edited

            Success on master using Chrome and IE8. Actually, not with extra points!

            dobedobedoh Andrew Nicols added a comment -

            Why no brownie points? I was looking forward to some chocolate!

            nebgor Aparup Banerjee added a comment - - edited

            lol, i think Fred is refering to "If you want extra brownie points, also apply the patch for MDL-33649 and..." in instructions . doh i think everyone already understood that now that i read comments properly. :-p

            stronk7 Eloy Lafuente (stronk7) added a comment -

            And this has been incorporated to all the weekly builds and also, to Moodle 2.3 Release Candidate 1, yay!

            Many, many thanks for your hard work!

            Ciao


              People

              • Votes:
                0 Vote for this issue
                Watchers:
                1 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:
                  Fix Release Date:
                  25/Jun/12