Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-33744

Cloze marks a correct numeric answer as a wrong one while using a comma as a decimal separator

    XMLWordPrintable

    Details

    • Affected Branches:
      MOODLE_22_STABLE
    • Story Points:
      3
    • Sprint:
      Internationals - 3.9 Sprint 1

      Description

      Hi,

      i created a simple demonstration of this bug. This cloze question:

      {1:NUMERICAL:=1.3:0.1}

      should have the correct answer "1.3". But when somebody types 1,3 then the answer is marked wrong, but it gives you full mark. See the attached screenshot for better explanation.

      Thanks

        Attachments

        1. error.jpg
          error.jpg
          185 kB
        2. MDL-33744-3.8.png
          MDL-33744-3.8.png
          254 kB
        3. MDL-33744-multianswer-question.xml
          0.5 kB

          Issue Links

            Activity

              People

              Assignee:
              rezaie9 Shamim Rezaie
              Reporter:
              aa007 Daniel Pospisil
              Participants:
              Component watchers:
              Tim Hunt, Andrew Lyons, Dongsheng Cai, Huong Nguyen, Jun Pataleta, Michael Hawkins, Shamim Rezaie, Simey Lameze
              Votes:
              3 Vote for this issue
              Watchers:
              8 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved:

                  Time Tracking

                  Estimated:
                  Original Estimate - Not Specified
                  Not Specified
                  Remaining:
                  Remaining Estimate - 0 minutes
                  0m
                  Logged:
                  Time Spent - 30 minutes
                  30m