Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-33841

Viewing folder hierarchy in filemanager list/tree view show small scrollbar.

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: 2.3
    • Fix Version/s: 2.3.2
    • Component/s: Filepicker
    • Labels:
      None
    • Testing Instructions:
      1. Login as admin
      2. Purge your caches.
      3. Add 5 level of folders to private file area and don't add any file on any level. (It should be hierarchy of folders only and no file)
      4. Save and view as list or tree.
      5. Make sure scroll bar is of same size as filemanager form element.
      6. Check in all supported browsers.
      Show
      Login as admin Purge your caches. Add 5 level of folders to private file area and don't add any file on any level. (It should be hierarchy of folders only and no file) Save and view as list or tree. Make sure scroll bar is of same size as filemanager form element. Check in all supported browsers.
    • Affected Branches:
      MOODLE_23_STABLE
    • Fixed Branches:
      MOODLE_23_STABLE
    • Pull Master Branch:
      wip-MDL-33841-master

      Description

      Viewing folder hierarchy in filemanager list/tree view show small scrollbar.

      In filemanager.css
      .filemanager .fp-content

      {overflow: auto;max-height: 472px;}

      should have min-height: 140px;

      Steps to reproduce:

      1. Login as admin
      2. Add 5 level of folders to private file area and don't add any file on any level. (It should be hierarchy of folders only and no file)
      3. Save and view as list or tree.
      4. Make sure scroll bar is of same size as filemanager form element.

        Gliffy Diagrams

          Attachments

            Issue Links

              Activity

              salvetore Michael de Raadt added a comment -

              I wasn't able to reproduce this under FF, Chrome or IE in Windows or FF or Chrom in Ubuntu.

              rajeshtaneja Rajesh Taneja added a comment -

              It happens if there is only one folder and no files on top level.

              barbararamiro Barbara Ramiro added a comment -

              I found out today that this one didn't make it to 2.3 because i didn't know at that time that I have to comment and click submit for integration and that those 3 pull url links were enough notice. Anyway, my mistake. This one should be ready for integration.

              samhemelryk Sam Hemelryk added a comment -

              Thanks Barbara, this has been integrated now

              barbararamiro Barbara Ramiro added a comment -

              Thanks Sam =)

              dmonllao David Monllaó added a comment -

              Tested on:

              • Linux
                • Firefox
                • Chrome
              • Windows
                • Firefox
                • IE 8
                • Safari

              Passes everywhere

              poltawski Dan Poltawski added a comment -

              *Notice*: Undefined variable: friendlyintegrator in /Users/danp/git/tokenintegrationthanks.php on line 26

              Congratulations

              {tracker.user.name}

              !

              You've made into Moodle

              {tracker.fixversion-1}

              +

              I would like to personally thank you for this contribution on behalf of all Moodle users throughout the world.

              cheers!

              {tracker.friendlyintegrator}

                People

                • Votes:
                  0 Vote for this issue
                  Watchers:
                  1 Start watching this issue

                  Dates

                  • Created:
                    Updated:
                    Resolved:
                    Fix Release Date:
                    10/Sep/12