Moodle
  1. Moodle
  2. MDL-33931

Fix the reverted 15% indent on form submit buttons in canvas themes and base

    Details

    • Type: Improvement Improvement
    • Status: Closed
    • Priority: Minor Minor
    • Resolution: Fixed
    • Affects Version/s: 2.3
    • Fix Version/s: 2.3
    • Component/s: Themes
    • Labels:
      None
    • Testing Instructions:
      1. Log in as the administrator.
      2. Navigate to [Navigation->My Home]
      3. Click 'Manage my private files' in the My private files block (Add the block if it is not present).
        [Test] The 'Save changes' and 'Cancel' buttons should be aligned with the other buttons and upload area of the form.
      4. Change the language to a right to left language.
      5. Select a course and either add an activity or edit an existing activity.
        [Test] The 'Save and return to course', 'Save and display', and 'Cancel' buttons should be aligned with the other elements on the page (drop down boxes etc.).

      Please test other forms and also different themes particularly 'nonzero' and 'binarius'.

      To add another language to your page

      • Go to [Settings->Site administration->Language->Language packs]
      • Select something like Hebrew (he) or Arabic (ar)
      • Go to the home page and there should be a select menu for changing languages
      Show
      Log in as the administrator. Navigate to [Navigation->My Home] Click 'Manage my private files' in the My private files block (Add the block if it is not present). [Test] The 'Save changes' and 'Cancel' buttons should be aligned with the other buttons and upload area of the form. Change the language to a right to left language. Select a course and either add an activity or edit an existing activity. [Test] The 'Save and return to course', 'Save and display', and 'Cancel' buttons should be aligned with the other elements on the page (drop down boxes etc.). Please test other forms and also different themes particularly 'nonzero' and 'binarius'. To add another language to your page Go to [Settings->Site administration->Language->Language packs] Select something like Hebrew (he) or Arabic (ar) Go to the home page and there should be a select menu for changing languages
    • Affected Branches:
      MOODLE_23_STABLE
    • Fixed Branches:
      MOODLE_23_STABLE
    • Pull from Repository:
    • Pull Master Branch:
      wip-MDL-33931-master

      Description

      The main forms were all improved nicely in MDL-33152 by fixing "base".

      It seems this was accidentally undone in the linked bug.

        Gliffy Diagrams

          Issue Links

            Activity

            Martin Dougiamas added a comment -

            Adrian identified this as a regression from MDL-32479

            Adrian Greeve added a comment -

            Hello Mary,

            I added you as a watcher to this issue because I would like your advice on this fix. As far as I can tell this alteration won't effect the right to left styles, but I'd like you to verify that for me.

            Many Thanks.

            Adrian Greeve added a comment - - edited

            Please note that this patch is made against the master integration branch.
            As the diff url won't show anything interesting, the line that I changed was theme/base/style/core.css line: 213

            .mform .fitem fieldset.felement {margin-left:15%;padding-left:1%;margin-bottom:0}
            

            Martin Dougiamas added a comment -

            Can you just quickly test that in some RTL languages? eg Hebrew or Arabic

            Mary Evans added a comment -

            Better check what's happening in MDL-32479 because Sam was dealing with that very thing. That small change in the .mform was done in error, and so Sam was going to reverse it to what you have here.

            Adrian Greeve added a comment -

            I've checked this in Arabic and Hebrew as well as a few other languages. The alignment works from left to right and from right to left. I'll have a chat with Sam when he gets back online.

            Sam Hemelryk added a comment -

            Thanks Adrian, this has been integrated now

            Sam Hemelryk added a comment -

            Tested and passed

            Eloy Lafuente (stronk7) added a comment -

            And this has been incorporated to all the weekly builds and also, to Moodle 2.3 Release Candidate 1, yay!

            Many, many thanks for your hard work!

            Ciao


              People

              • Votes:
                0 Vote for this issue
                Watchers:
                4 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: