Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-33999

folder renaming in filemanager should say 'ok' instead of 'delete' in confirmation dialog

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: 2.3
    • Fix Version/s: 2.3
    • Component/s: Filepicker
    • Labels:
      None
    • Testing Instructions:

      1) create a folder in filemanager .
      2) now go back and rename that same folder. and save changes. there will be a dialog asking you to confirm the renaming. it should show 'ok' and 'cancel' buttons.

      Show
      1) create a folder in filemanager . 2) now go back and rename that same folder. and save changes. there will be a dialog asking you to confirm the renaming. it should show 'ok' and 'cancel' buttons.
    • Affected Branches:
      MOODLE_23_STABLE
    • Fixed Branches:
      MOODLE_23_STABLE
    • Pull from Repository:
    • Pull Master Branch:

      Description

      this is a quick fix regression noticed from MDL-33130. (fixing now)

        Gliffy Diagrams

          Attachments

            Issue Links

              Activity

              nebgor Aparup Banerjee added a comment -

              created patch for integration.

              poltawski Dan Poltawski added a comment -

              Integrated

              poltawski Dan Poltawski added a comment -

              Passing, but I think there is a new issue here, because the intention of that other change was to convert that delete button, so that should be changed properly.

              dougiamas Martin Dougiamas added a comment -

              In fact I think we should just get rid of those confirm dialogs anyway (in 2.4)

              It's all a draft file area and nothing is saved until you save the whole area anyway.

              stronk7 Eloy Lafuente (stronk7) added a comment -

              Yay. just in time for Moodle 2.3 release! Many thanks!

              Closing as fixed, ciao


                People

                • Votes:
                  0 Vote for this issue
                  Watchers:
                  0 Start watching this issue

                  Dates

                  • Created:
                    Updated:
                    Resolved:
                    Fix Release Date:
                    25/Jun/12