Moodle
  1. Moodle
  2. MDL-34003

In Moodle 2.2 I have uploaded the Common cartridge 1.1 file, the file with webcontent type is not uploaded, only the text inside the body tag is displayed in the moodle page.

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Minor Minor
    • Resolution: Won't Fix
    • Affects Version/s: 2.2.1
    • Fix Version/s: None
    • Component/s: Backup: IMS-CC
    • Labels:
      None
    • Affected Branches:
      MOODLE_22_STABLE
    • Rank:
      42114

      Description

      I have taken a backup of the course in Common Cartridge 1.1 format and restored the same file.
      In the course I have created a File and mapped to an HTML.
      In the restored Common Cartridge course it was changed to Page and contains only the content that was inside the body tag of the HTML.

      Kindly help to resolve the issue.

        Activity

        Hide
        Darko Miletic added a comment -

        This behavior is by design. During implementation of the CC export we opted for exporting page resources in Moodle courses as items with HTML file. Links to a physical HTML file in a course are also exported as an item linked to the HTML file. During import it is not possible to distinguish if the item link was originaly page or link to a static file. Hence this behavior. We deemed more user friendly to use Moodle page resource for these cases.

        Show
        Darko Miletic added a comment - This behavior is by design. During implementation of the CC export we opted for exporting page resources in Moodle courses as items with HTML file. Links to a physical HTML file in a course are also exported as an item linked to the HTML file. During import it is not possible to distinguish if the item link was originaly page or link to a static file. Hence this behavior. We deemed more user friendly to use Moodle page resource for these cases.
        Hide
        Michael de Raadt added a comment -

        Thanks for reporting this issue.

        We have detected that this issue has been inactive for over a year. It was reported as affecting versions that are no longer supported.

        If you believe that this issue is still relevant to current versions (2.5 and beyond), please comment on the issue. Issues left inactive for a further month will be closed.

        Michael d.

        TW9vZGxlDQo=

        Show
        Michael de Raadt added a comment - Thanks for reporting this issue. We have detected that this issue has been inactive for over a year. It was reported as affecting versions that are no longer supported. If you believe that this issue is still relevant to current versions (2.5 and beyond), please comment on the issue. Issues left inactive for a further month will be closed. Michael d. TW9vZGxlDQo=
        Hide
        Michael de Raadt added a comment -

        I'm closing this issue as it has been inactive for over a year has been recorded as affecting versions that are no longer supported.

        This is being done as part of a bulk annual clean-up of issues.

        If you still believe this is an issue in supported versions, please create a new issue.

        Show
        Michael de Raadt added a comment - I'm closing this issue as it has been inactive for over a year has been recorded as affecting versions that are no longer supported. This is being done as part of a bulk annual clean-up of issues. If you still believe this is an issue in supported versions, please create a new issue.

          People

          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: