Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Minor Minor
    • Resolution: Not a bug
    • Affects Version/s: 2.3, 2.3.1
    • Fix Version/s: None
    • Component/s: Navigation
    • Labels:
      None
    • Affected Branches:
      MOODLE_23_STABLE
    • Rank:
      42325

      Description

      The links (drop-downs) in the side menu are not opening (Site Administration, Site Pages, etc)

      using: Windows Server 2008 R2 / Windows 7 Enterprise (Testing)
      Microsoft SQL Server 2008 Express
      Microsoft IIS 7.5 web server
      PHP 5.3.10

        Activity

        Mary Cooch added a comment -

        I just wondered if this is related at all to this MDL-31678

        Sam Hemelryk added a comment -

        Hi Mary, it may well have.

        Zweni, could you please go and have a read of MDL-31678 (particularly the last post I made there) and seeing if anything there helps you.
        The two most common causes of the settings/navigation expansion breaking is caused because there is a JS error on the page or not all of the JS could be loaded.
        Could you please check using your browser and see if there are any reported JS errors and report them here if there are.

        Cheers
        Sam

        Zweni Nkabinde added a comment -

        Hi Sam
        Hi Mary

        Thanks for referring me to that. I didn't realise there was another logged issue on the topic. Anyway, I have tried this with script debugging on (IE9) and no errors are reported by the browser when I click on the drop-downs. I have JavaScript turned on also. I have also confirmed that the debugger is on, since the landing page (home page) on Moodle issues a 'YUI' error.

        I also noticed that MDL-31678 affected version 2.2.1, which we had no navigation issues with.

        Thanks

        Zweni Nkabinde added a comment -

        Hi guys

        I've found the "problem" with the new distribution of Moodle. The included affected versions on this issue do not work with the standard CGI module in IIS7.5, rather use the "FastCGI" module. This problem goes away and the side links open.

        Thanks for your help and all the effort you have put in this issue. I hope this helps somebody else

        Sam Hemelryk added a comment -

        Thanks Zweni, glad you found the issue and a solution.


          People

          • Votes:
            1 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: