Moodle
  1. Moodle
  2. MDL-34044

Broken markup for course prerequisites in Course Completion Status block

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Minor Minor
    • Resolution: Fixed
    • Affects Version/s: 2.1.6, 2.2.3, 2.3
    • Fix Version/s: 2.1.7, 2.2.4, 2.3.1
    • Component/s: Course completion
    • Labels:
      None
    • Testing Instructions:
      • Enable course completion across the website in Advanced Features
      • Create 2 courses with completion enabled, and enable Self-completion criteria for both in Completion tracking settings
      • Create a third course with completion enabled, add both other courses as prerequisites in Completion tracking settings
      • Add the Completion Status block to the course
      • Enrol a user in the course
      • View the course as the enrolled user

      Before fix:

      • the "0 of 2" string indicating prerequisites completed appears out of order at the start of the block's output

      After fix:

      • the "0 of 2" string appears beside the string "Prerequisites completed"
      Show
      Enable course completion across the website in Advanced Features Create 2 courses with completion enabled, and enable Self-completion criteria for both in Completion tracking settings Create a third course with completion enabled, add both other courses as prerequisites in Completion tracking settings Add the Completion Status block to the course Enrol a user in the course View the course as the enrolled user Before fix: the "0 of 2" string indicating prerequisites completed appears out of order at the start of the block's output After fix: the "0 of 2" string appears beside the string "Prerequisites completed"
    • Affected Branches:
      MOODLE_21_STABLE, MOODLE_22_STABLE, MOODLE_23_STABLE
    • Fixed Branches:
      MOODLE_21_STABLE, MOODLE_22_STABLE, MOODLE_23_STABLE
    • Pull Master Branch:

      Description

      This is a regression caused by MDL-26626, just a bad copy and paste.

        Gliffy Diagrams

          Issue Links

            Activity

            Aaron Barnes added a comment -

            Once this passes peer review I'll apply the patch to the other affected branches

            Jason Fowler added a comment -

            All looks good to me Aaron

            Sam Hemelryk added a comment -

            Thanks Aaron, changes looked good and have been integrated now.

            Sam Hemelryk added a comment -

            Tested and passed thanks Aaron.

            Eloy Lafuente (stronk7) added a comment -

            Closing this as fixed, changes are now available upstream.

            Big thanks!


              People

              • Votes:
                0 Vote for this issue
                Watchers:
                0 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: