Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-34097

Decide Moodle 2.4 requirements and push them to environment.xml

    Details

    • Type: Task
    • Status: Closed
    • Priority: Critical
    • Resolution: Fixed
    • Affects Version/s: 2.1, 2.2, 2.3, 2.4
    • Fix Version/s: 2.2.5, 2.3.2
    • Component/s: Installation
    • Labels:
    • Testing Instructions:
      Hide

      0) To test exclusively in stable branches (from 22 to 23)
      1) Go to admin -> server -> environment
      2) One "2.4 upwards" Moodle version should be available
      3) It shows the same requirements as 2.3

      Show
      0) To test exclusively in stable branches (from 22 to 23) 1) Go to admin -> server -> environment 2) One "2.4 upwards" Moodle version should be available 3) It shows the same requirements as 2.3
    • Difficulty:
      Moderate
    • Affected Branches:
      MOODLE_21_STABLE, MOODLE_22_STABLE, MOODLE_23_STABLE, MOODLE_24_STABLE
    • Fixed Branches:
      MOODLE_22_STABLE, MOODLE_23_STABLE
    • Pull from Repository:
    • Pull Master Branch:
      w36_MDL-34097_m24_environment

      Description

      We need to decide ASAP about all the PHP/DB/Moodle versions requirements and put all them into the environmental tests (adding them to all supported branches).

      Ciao

        Gliffy Diagrams

          Issue Links

            Activity

            Hide
            skodak Petr Skoda added a comment -

            my +1 to implement "regex utf-8" requirement - optional in 2.4 and mandatory in 2.5

            Show
            skodak Petr Skoda added a comment - my +1 to implement "regex utf-8" requirement - optional in 2.4 and mandatory in 2.5
            Hide
            skodak Petr Skoda added a comment -

            I suppose it is already too late to change the requirements, I suppose the major unicode regex has to wait till 2.5, sorry...

            Show
            skodak Petr Skoda added a comment - I suppose it is already too late to change the requirements, I suppose the major unicode regex has to wait till 2.5, sorry...
            Hide
            stronk7 Eloy Lafuente (stronk7) added a comment -

            Petr, should we be backporting MDL-19071 to 22_STABLE? As far as 2.4 can upgrade from 2.2 and 2.3 I think it would be great to have that test in 2.2 too... any drawback?

            Show
            stronk7 Eloy Lafuente (stronk7) added a comment - Petr, should we be backporting MDL-19071 to 22_STABLE? As far as 2.4 can upgrade from 2.2 and 2.3 I think it would be great to have that test in 2.2 too... any drawback?
            Hide
            skodak Petr Skoda added a comment -

            2.3/2.4 sort of works, the regex is not used much during upgrade, I suppose it is enough to warn them only.

            Show
            skodak Petr Skoda added a comment - 2.3/2.4 sort of works, the regex is not used much during upgrade, I suppose it is enough to warn them only.
            Hide
            stronk7 Eloy Lafuente (stronk7) added a comment -

            yesyes, what I say is that people upgrading from 2.2 to 2.3 or 2.4 does not see the warning in advance (admin->server->environment), because MDL-19071 was not backported to 2.2. So they only discover the buggy regexp once they start the upgrade.

            Show
            stronk7 Eloy Lafuente (stronk7) added a comment - yesyes, what I say is that people upgrading from 2.2 to 2.3 or 2.4 does not see the warning in advance (admin->server->environment), because MDL-19071 was not backported to 2.2. So they only discover the buggy regexp once they start the upgrade.
            Hide
            skodak Petr Skoda added a comment -

            But that regex problem affects them already in 2.2.x or earlier versions and all other PHP software that uses utf-8 encoding. The warning does not stop you from upgrading to 2.3/2.4 and the upgrade is not going to fail.

            Show
            skodak Petr Skoda added a comment - But that regex problem affects them already in 2.2.x or earlier versions and all other PHP software that uses utf-8 encoding. The warning does not stop you from upgrading to 2.3/2.4 and the upgrade is not going to fail.
            Hide
            stronk7 Eloy Lafuente (stronk7) added a comment -

            Oki, so they don't "discover" the problem until they try to upgrade to 2.3/2.4. Oki, I can live with that (still think it's better to show them the problem @ 2.2 admin page but...)

            Integrating... thanks!

            Show
            stronk7 Eloy Lafuente (stronk7) added a comment - Oki, so they don't "discover" the problem until they try to upgrade to 2.3/2.4. Oki, I can live with that (still think it's better to show them the problem @ 2.2 admin page but...) Integrating... thanks!
            Hide
            stronk7 Eloy Lafuente (stronk7) added a comment -

            (also note it's futile to put a different xml to 2.2 users because they will be downloading the master version from download.moodle.org sooner or later. I hope that won't break and the regexp test is simply skipped).

            Show
            stronk7 Eloy Lafuente (stronk7) added a comment - (also note it's futile to put a different xml to 2.2 users because they will be downloading the master version from download.moodle.org sooner or later. I hope that won't break and the regexp test is simply skipped).
            Hide
            skodak Petr Skoda added a comment -

            ok, makes sense, anything unknown in environment.xml should be skipped, if not it is a separate bug.

            Show
            skodak Petr Skoda added a comment - ok, makes sense, anything unknown in environment.xml should be skipped, if not it is a separate bug.
            Hide
            stronk7 Eloy Lafuente (stronk7) added a comment -

            Integrated (22, 23 and master), thanks!

            Show
            stronk7 Eloy Lafuente (stronk7) added a comment - Integrated (22, 23 and master), thanks!
            Hide
            fred Frédéric Massart added a comment -

            Test passed. Although please note that the settings between 2.2 and (2.3 | 2.4) are different as the hash extension is required.

            Show
            fred Frédéric Massart added a comment - Test passed. Although please note that the settings between 2.2 and (2.3 | 2.4) are different as the hash extension is required.
            Hide
            stronk7 Eloy Lafuente (stronk7) added a comment -

            Many thanks for the hard work.

            These changes have been spread upstream and are already available in the git and cvs repositories.

            Ciao

            Show
            stronk7 Eloy Lafuente (stronk7) added a comment - Many thanks for the hard work. These changes have been spread upstream and are already available in the git and cvs repositories. Ciao

              People

              • Votes:
                0 Vote for this issue
                Watchers:
                2 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:
                  Fix Release Date:
                  10/Sep/12