Moodle
  1. Moodle
  2. MDL-3418

grade book dumps me back to login

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Trivial Trivial
    • Resolution: Fixed
    • Affects Version/s: 1.5
    • Fix Version/s: None
    • Component/s: Gradebook
    • Labels:
      None
    • Environment:
      Linux
    • Database:
      MySQL
    • Affected Branches:
      MOODLE_15_STABLE
    • Rank:
      14396

      Description

      Using the latest 1.5beta (downloaded 3 June).

      When looking at the grades (as a student) for a class that hasn't set any work I, correctly, get a message box saying that no grades were returned and there is a Continue button.

      When I click the continue button I am returned to the Login screen and have been logged out.

        Activity

        Hide
        Martin Dougiamas added a comment -

        From Shane Elliott (shane at pukunui.com) Monday, 6 June 2005, 08:18 AM:

        The continue button was trying to take you back to the site page. This has now been changed in CVS to take you back to the course page which is really the expected behaviour.

        As to why you were required to login again when redirected to the site page, this is most likely something to do with your settings.

        One possible problem (which I can use to replicate your situation) is using links to courses such as http://mymoodle.site/course/view.php?id=xx when $CFG->wwwroot is set to www.mymoodle.site

        The cookies used for sessions distinguish between www.mymoodle.site and mymoodle.site

        In this case the solution is to change either the link or the value of $CFG->wwwroot in config.php

        HTH

        Show
        Martin Dougiamas added a comment - From Shane Elliott (shane at pukunui.com) Monday, 6 June 2005, 08:18 AM: The continue button was trying to take you back to the site page. This has now been changed in CVS to take you back to the course page which is really the expected behaviour. As to why you were required to login again when redirected to the site page, this is most likely something to do with your settings. One possible problem (which I can use to replicate your situation) is using links to courses such as http://mymoodle.site/course/view.php?id=xx when $CFG->wwwroot is set to www.mymoodle.site The cookies used for sessions distinguish between www.mymoodle.site and mymoodle.site In this case the solution is to change either the link or the value of $CFG->wwwroot in config.php HTH
        Hide
        Michael Blake added a comment -

        assign to a valid user

        Show
        Michael Blake added a comment - assign to a valid user

          People

          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: