Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-34213

Clicking Manage link in Firefox opens manage url and current page again

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: 2.3, 2.3.1
    • Fix Version/s: 2.3.2
    • Component/s: Filepicker
    • Labels:
      None
    • Testing Instructions:

      Use Firefox (reporter tested under OSX with v13.1 and Windows 7)

      1. Enable the flickr repository type (or some other repository type that has a manage link).
      2. In a course, turn editing on, add a file or URL resource. Select the flickr (or other repository type) in the file picker and click the manage link.
      3. Make sure only one window with flickr page is opened

      Show
      Use Firefox (reporter tested under OSX with v13.1 and Windows 7) 1. Enable the flickr repository type (or some other repository type that has a manage link). 2. In a course, turn editing on, add a file or URL resource. Select the flickr (or other repository type) in the file picker and click the manage link. 3. Make sure only one window with flickr page is opened
    • Affected Branches:
      MOODLE_23_STABLE
    • Fixed Branches:
      MOODLE_23_STABLE
    • Pull Master Branch:
      wip-MDL-34213-master

      Description

      Enable the flickr repository type (or some other repository type that has a manage link).

      In Firefox (tested under OSX with v13.1 and Windows 7)

      In a course, turn editing on, add a file or URL resource. Select the flickr (or other repository type) in the file picker and click the manage link. Two tabs should be opened, one to the flickr page and another to the add a new file page that was already open (see screenshots).

        Gliffy Diagrams

          Attachments

            Activity

            nmares Nathan Mares added a comment -

            Screenshots and patch attached

            marina Marina Glancy added a comment -

            Hi Nathan,
            Thank you for reporting it. I could not reproduce the bug and your patch looked strange to me because return value in this case is not analysed. But I noticed another mistype that might have caused the error in your case.
            Can you please apply my patch (don't forget to purge the cache) and re-test your case.

            marina Marina Glancy added a comment -

            TO INTEGRATORS: please cherry-pick in 2.3

            nmares Nathan Mares added a comment -

            Ahh you're right! That fixed it for me.. Thanks

            poltawski Dan Poltawski added a comment -

            The main moodle.git repository has just been updated with latest weekly modifications. You may wish to rebase your PULL branches to simplify history and avoid any possible merge conflicts. This would also make integrator's life easier next week.

            TIA and ciao

            poltawski Dan Poltawski added a comment -

            Thanks Marina, this has been integrated now.

            dmonllao David Monllaó added a comment -

            Tested in master. It passes

            poltawski Dan Poltawski added a comment -

            *Notice*: Undefined variable: friendlyintegrator in /Users/danp/git/tokenintegrationthanks.php on line 26

            Congratulations

            {tracker.user.name}

            !

            You've made into Moodle

            {tracker.fixversion-1}

            +

            I would like to personally thank you for this contribution on behalf of all Moodle users throughout the world.

            cheers!

            {tracker.friendlyintegrator}

              People

              • Votes:
                0 Vote for this issue
                Watchers:
                0 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:
                  Fix Release Date:
                  10/Sep/12