Moodle
  1. Moodle
  2. MDL-34226

Block Quiz Navigation shows cloze question as answered even though it´s not.

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Minor Minor
    • Resolution: Fixed
    • Affects Version/s: 2.2.2
    • Fix Version/s: 2.2.5, 2.3.2
    • Component/s: Quiz
    • Labels:
      None
    • Testing Instructions:

      0. Run the unit tests (2.3+)

      1. Create a Cloze question comprising just multi-choice subquestions. e.g.

      Match the following cities with the correct state:
      * San Francisco: {1:MULTICHOICE:=California#OK~Arizona#Wrong}
      * Tucson: {1:MULTICHOICE:California#Wrong~%100%Arizona#OK}
      * Los Angeles: {1:MULTICHOICE:=California#OK~Arizona#Wrong}
      * Phoenix: {1:MULTICHOICE:%0%California#Wrong~=Arizona#OK}
      

      2. Add the question to a quiz using Deferred feedback mode.

      3. Preview the quiz. When you get to the Cloze question, answer one part, but leave the other parts blank.

      4. Click next. The state of the Cloze questions should not change to 'Answer saved'. It should change to 'Incomplete answer'.

      Show
      0. Run the unit tests (2.3+) 1. Create a Cloze question comprising just multi-choice subquestions. e.g. Match the following cities with the correct state: * San Francisco: {1:MULTICHOICE:=California#OK~Arizona#Wrong} * Tucson: {1:MULTICHOICE:California#Wrong~%100%Arizona#OK} * Los Angeles: {1:MULTICHOICE:=California#OK~Arizona#Wrong} * Phoenix: {1:MULTICHOICE:%0%California#Wrong~=Arizona#OK} 2. Add the question to a quiz using Deferred feedback mode. 3. Preview the quiz. When you get to the Cloze question, answer one part, but leave the other parts blank. 4. Click next. The state of the Cloze questions should not change to 'Answer saved'. It should change to 'Incomplete answer'.
    • Affected Branches:
      MOODLE_22_STABLE
    • Fixed Branches:
      MOODLE_22_STABLE, MOODLE_23_STABLE
    • Pull from Repository:
    • Pull Master Branch:
    • Rank:
      42567

      Description

      Inside our Moodle 2.2.2 (20120329) version we are using the quiz navigation block that comes with the quiz module. This block lists every question inside the quiz inside a square and numbers it. After answering a question the square inside the block turns grey. If a student continues to the next question without answering the previous one, the square stays grey.

      A peculiar situation happens when the test contains an embedded (cloze) question. Upon clicking the next button without answering the question, the square inside the quiz navigation block turns grey. This might confuse students thinking they have answered the question. The same effect occurs when using the standard theme.

      I have some screenshots illustrating the functionality and the undesired effect. I have blurred the content text because these screenshots were taken from a live environment from one of our clients.
      Picture 1: This shows the block with grey and white squares. The grey squares are answered questions
      http://www.avetica.nl/Pic2.png

      Picture 2: This shows an embedded question (cloze)
      http://www.avetica.nl/Pic1.png

      Picture 3: upon clicking "continue" the square turns grey. Even though the question wasn't answered
      http://www.avetica.nl/Pic3.png

      How to reproduce:
      1. Create multiple choice questions
      2. Create embedded (cloze) questions
      3. Create a test including the questions
      4. Make sure the test is shown with the quiz navigation block
      5. See the functionality of the block when answering a multiple choice question (square turns grey) and not answering one (square stays white).
      6. Do not answer an embedded (cloze) question and see the square turning grey.

        Activity

        Tim Hunt added a comment -

        What is the 'How questions behave' setting for your quiz?

        Tim Hunt added a comment -

        I cannot reproduce this (using Deferred feedback behaviour, which I think is what you are using based on the screen-grabs, and latest 2.3.1+).

        Please can you provide more detailed steps to reproduce.

        Virgil Ashruf added a comment -

        The test is using Deferred feedback behaviour. To reproduce this I create a test. This test only has 1 possible attempt for the user.

        To reproduce the behaviour I have taken the following steps:
        1. Create a new test
        2. Add question: Information
        3. Add question: Multiple choice
        4. Add question: Embedded (cloze)
        5. Take the test
        6. See the information block turning grey after you have viewed it.
        7. See the multiple choice question only turn grey after you have answered it
        8. See the Embedded question and do not answer it, instead return to the previous question. The question turns grey in the block.

        I hope this helps.

        Tim Hunt added a comment -

        To trigger the problem, you need to

        1. create the Cloze question using only multiple choice questions.

        2. Answer at least one, but not all, parts of the Cloze question before clicking Next.

        Tim Hunt added a comment -

        Submitting for integration.

        Note that I wrote a basic unit test, but did not bother to back-port it to 2.2.

        Dan Poltawski added a comment -

        The main moodle.git repository has just been updated with latest weekly modifications. You may wish to rebase your PULL branches to simplify history and avoid any possible merge conflicts. This would also make integrator's life easier next week.

        TIA and ciao

        Dan Poltawski added a comment -

        Thanks Tim,

        I've integrated this now.

        Rajesh Taneja added a comment -

        Works Great, status is set to incomplete answer.

        Thanks for fixing this, Tim.

        Aparup Banerjee added a comment -

        yay, it works!

        This issue has been put through rigorous processes and finally swam upstream along with some 65 others this week.

        Thank you all for taking the time to get us here.

        cheers!


          People

          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: