Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-34370

Fusion theme: can't move weeks in Fusion

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: 2.3.1
    • Fix Version/s: 2.3.2
    • Component/s: Themes
    • Labels:
    • Testing Instructions:
      1. Select Fusion theme from Theme selector (NOT by URL)
      2. Go to a course page that uses 'Weekly format'.
      3. TEST that when editing is enabled that you can move the weeks up or down
      4. TEST also that the colour of the CURRENT week's 'section name' (previously termed 'weekdates' in Moodle 1.9 through to 2.2) is pale blue.
      Show
      Select Fusion theme from Theme selector (NOT by URL) Go to a course page that uses 'Weekly format'. TEST that when editing is enabled that you can move the weeks up or down TEST also that the colour of the CURRENT week's 'section name' (previously termed 'weekdates' in Moodle 1.9 through to 2.2) is pale blue.
    • Workaround:

      In my custom theme, I have overridden the display like this:

      .course-content .weeks .section.main .left {
      display: inline;
      }

      As a result, the icon does show up, but it is inside the week section - I suppose I could specify a width for the left margin in weekly format

      Show
      In my custom theme, I have overridden the display like this: .course-content .weeks .section.main .left { display: inline; } As a result, the icon does show up, but it is inside the week section - I suppose I could specify a width for the left margin in weekly format
    • Affected Branches:
      MOODLE_23_STABLE
    • Fixed Branches:
      MOODLE_23_STABLE
    • Pull Master Branch:
      MDL-34370_master

      Description

      in FF (haven't tested it in other browsers), when in a course in weekly format, it is not possible to move weeks as the ajax move icon, which is supposed to show on the left of the week section, is hidden (OK in Topics format though).

      It's due to line 279 & following in fusion core.css:

      .course-content .weeks .section.main .left {
      display: none;
      }

      It states that the left margin of a week should be hidden (probably because the margin is defined as 0 in line 276:

      .course-content .weeks .section.main .content {
      margin-left: 0;
      }

      See screenshots

        Gliffy Diagrams

          Activity

          jiel Jean-Luc Delghust added a comment -

          as you can see, no move icon on the left of he sections

          jiel Jean-Luc Delghust added a comment -

          On topics format, the icon does appear on the left

          salvetore Michael de Raadt added a comment -

          I can confirm this.

          lazydaisy Mary Evans added a comment -

          This will hopefully get done this weekend ready for next integration slot.

          samhemelryk Sam Hemelryk added a comment -

          Thanks Mary, this has been integrated now

          andyjdavis Andrew Davis added a comment -

          Looks good. Passing.

          nebgor Aparup Banerjee added a comment -

          yay, it works!

          This issue has been put through rigorous processes and finally swam upstream along with some 65 others this week.

          Thank you all for taking the time to get us here.

          cheers!


            People

            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:
                Fix Release Date:
                10/Sep/12