Moodle
  1. Moodle
  2. MDL-34391

Activities in hidden topic cannot be toggled visible/hidden using show/hide icon

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Cannot Reproduce
    • Affects Version/s: 2.3.1
    • Fix Version/s: None
    • Component/s: Course
    • Labels:
    • Affected Branches:
      MOODLE_23_STABLE
    • Rank:
      42786

      Description

      When you have a topic box that you have marked hidden, it correctly marks all the items inside of it hidden as well. We have many users that like to keep files and other items in a hidden topic box, but the activities/files/etc themselves as not hidden. This allows them to link to those in various places throughout the site, and avoid cluttering up the front page for students.

      They are still able to go into the 'update' button and in the 'common module' setting flip it to visible and achieve the desired result, but this quite a bit slower then being able to use the icon. It seems like one way or the other this should be standardized.

        Issue Links

          Activity

          Patrick Mulrooney added a comment -

          Steps to reproduce:

          1. Create a course with at least one topic
          2. Add activities to that topic
          3. Go in to editing mode
          4. Click Show/hide for an activity in your block, it will toggle
          5. Click to toggle the Topic block hidden. All activities are now hidden (no issue here)
          6. Try to toggle one of the hidden activities so it is visible, nothing happens.
          7. Go in to 'update' update for the activity and scroll to bottom switching the activity visibility from 'hide' to 'show'.
          8. The activity is now not hidden
          Michael de Raadt added a comment -

          Thanks for reporting this. I was able to replicate the problem. It seems to affect 2.3+ only. I'll have a quick look for the cause of this regression.

          I've put it on our backlog.

          If you are able to provide a patch or links to your Git repository branch, please add a patch label so we will spot it.

          Michael de Raadt added a comment -

          I'm not sure if the issue was caused by the introduction of the page format or one of the subsequent issues that followed it.

          Dan Poltawski added a comment -

          This is related to the course ajax changes, and I think its by design. (Right, Andrew?)

          I seem to remember bugs asking for the opposite.

          Andrew Nicols added a comment -

          MDL-25990 is the issue you're thinking of Dan - as you say, this was by design and was a requested change. It's easy enough to remove, but we could really do with some guidance on what the true desired behaviour is.

          If the desired behaviour is to not allow toggles, then the mod_form should also not allow the visibility to be toggled.

          Rex Lorenzo added a comment -

          Before, I reported that Visible content in Hidden sections is accessible (MDL-35699) and was told that is expected behavior.

          Just ran into this issue today that I couldn't unhide hidden content in a hidden section. So the patch for MDL-25990 should be reverted and allow the unhiding of content in hidden sections.

          Unhiding content in hidden sections should be an allowable thing, so even this ticket (MDL-37162 - Use CSS to make mod show/hide icons not look "clickable" in hidden sections) should not be integrated.

          Paul Nicholls added a comment -

          Rex,
          MDL-37162 is based on the current intended behaviour - it's a performance improvement which does not change the behaviour, so should still be integrated. If the decision is made to change this behaviour, a subsequent change can be made (attached to this issue - MDL-34391) which removes the single CSS rule added by MDL-37162 and the few lines of JS in toggle_hide_resource() in course/yui/toolboxes/toolboxes.js (or adjusts them as necessary to turn it into an optional setting, if that's the direction chosen).

          Dan Poltawski added a comment -

          Hi Everyone,

          I believe this issue was fixed by the chain of issues discovered in MDL-38700, MDL-38703 and MDL-38713.

          Please let me know if you are still able to reproduce this issue.

          Kirill Astashov added a comment -

          This is still the case as of 2.3.8+ (Build: 20130712)

          Marina Glancy added a comment -

          This is sort of contradictory request to MDL-13966

          Kirill Astashov added a comment -

          This issue does not look related to MDL-13966 . Here we are talking about activities in hidden sections. They can be hidden/unhidden from the edit screen but not from the course view (eye icon does not work for them) which is inconsistent.


            People

            • Votes:
              1 Vote for this issue
              Watchers:
              9 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: