Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-34494

Formal White report.php uses old style MAIN_CONTENT_TOKEN

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: 2.3, 2.4
    • Fix Version/s: 2.3.2
    • Component/s: Themes
    • Labels:

      Description

      In checking Formal White theme in order to answer a query today, concerning the report layout, I discovered that theme/formal_white/layout/report.php still uses the old MAIN_CONTENT_TOKEN. This is a regression, as the previous version (Moodle 2.2.4) although that uses general.php for the report layout, nevertheless is uses the correct form of $OUTPUT->main_content().

        Gliffy Diagrams

          Attachments

            Activity

            lazydaisy Mary Evans added a comment -

            Can you deal with this Danielle of do you want me to fix it?

            daniss Daniele Cordella added a comment -

            Ciao Mary
            and thanks for this report.
            I made a correction following your suggestion. Can you check it please.
            It should really be safe.
            Let me know, please.
            Ciao.
            Happy Olympics games.

            lazydaisy Mary Evans added a comment -

            Starting Peer Review

            lazydaisy Mary Evans added a comment -

            Looks good to me.
            I'll set it to start Integration Review.

            lazydaisy Mary Evans added a comment -

            Hi Daniele,

            I have just submitted this for Integration Review.

            But could you also fix Moodle 2.3 branch too? Otherwise the fix will not be in the next release.

            daniss Daniele Cordella added a comment -

            Mary, I added the fix for m23 too.
            Ciao.

            samhemelryk Sam Hemelryk added a comment -

            Thanks Daniele and Mary, this has been integrated now

            andyjdavis Andrew Davis added a comment -

            This seems to be missing testing instructions. I can click around formal white but I'm not quite sure what I should be doing.

            samhemelryk Sam Hemelryk added a comment -

            Aha safe to pass then thanks Andrew.
            Sorry I should have marked this as tested and passed when I integrated it.

            Accurate testing instructions would be.

            1. Change to the formal white theme
            2. Check any page and make sure the content area contains its normal stuff.
            andyjdavis Andrew Davis added a comment -

            Had a decent click around. All looks good. Passing.

            poltawski Dan Poltawski added a comment -

            asko, Дзякуй, ধন্যবাদ, Благодаря, Gràcies, 感谢, 謝謝, Hvala, Díky, Tak, Bedankt, Tänan, متشکریم, Salamat, Kiitokset, Merci, Grazas, Danke, Ευχαριστώ, આભાર, תודה, धन्यवाद, Köszönjük, Takk fyrir, Terima Kasih, Grazie, ありがとうございます, Рахмет, សូមអរគុណ, 감사합니다, gratiās, Pateicamies, Ačiū, Благодарам, Tēnā koa, Kia Ora Rawa Atu, आभारी आहोत, Талархал, Takk, Dziękuję, Obrigado, Mulţumesc, Engraziel, Спасибо, Fa'afetai, Хвала, Hvala, ස්තූතියි, Vďaka, Hvala, Mahadsanid, Thanks, Gracias, Tack, Salamat, நன்றி, నెనరులు, ขอบคุณค่ะ!

            Your work has made it into this weeks Moodle release! There are no gold medals available this week - but millions around the world will benefit. Thank you!


              People

              • Votes:
                0 Vote for this issue
                Watchers:
                1 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:
                  Fix Release Date:
                  10/Sep/12