Details

    • Type: Sub-task Sub-task
    • Status: Closed
    • Priority: Minor Minor
    • Resolution: Fixed
    • Affects Version/s: 2.3.1, 2.4
    • Fix Version/s: 2.4
    • Component/s: Themes
    • Labels:
    • Testing Instructions:

      NB: Please ensure you have a custom menu set in Themes settings prior to testing.

      1. Select CANVAS theme using theme selector. (NOT by URL)
      2. Ensure AJAX & JavaScript are enabled.
      3. Turn editing on and TEST drag-n-drop works when moving blocks.
      4. With editing still enabled TEST docking and un-docking all blocks.
      5. Turn editing off then TEST docking and un-docking all blocks.
      6. TEST 3,4 & 5 in Home page, Course page and Report page for consistency
      7. Test to see that the Custom Menu is displayed and works correctly
      Show
      NB: Please ensure you have a custom menu set in Themes settings prior to testing. Select CANVAS theme using theme selector. (NOT by URL) Ensure AJAX & JavaScript are enabled. Turn editing on and TEST drag-n-drop works when moving blocks. With editing still enabled TEST docking and un-docking all blocks. Turn editing off then TEST docking and un-docking all blocks. TEST 3,4 & 5 in Home page, Course page and Report page for consistency Test to see that the Custom Menu is displayed and works correctly
    • Affected Branches:
      MOODLE_23_STABLE, MOODLE_24_STABLE
    • Fixed Branches:
      MOODLE_24_STABLE
    • Rank:
      42950

      Description

      block-region classes are a necessary requirement in layout files for themes to be able to work correctly when using AJAX drag-n-drop. At the moment CANVAS is missing these from region-post and region-pre in canvas/layout files.

      Also, like BASE theme, CANVAS should have the custommenu php in the layout files too, so that if CANVAS is copied to use as a base for new themes all the php is included that needs to be.

        Issue Links

          Activity

          Mary Evans added a comment -

          I'm working on this now hoping to get it finished soon.

          Sam Hemelryk added a comment -

          Thanks Mary, this has been integrated now

          Andrew Davis added a comment -

          It all seems to work fine except for being able to drag and drop blocks on the course reports. I tried the participation report and activity completion. The non-ajax block moving works fine and dragging and dropping works fine on the site front page and the course page but I dont seem to be able to grab the blocks and move them around on the course reports.

          I'm using the theme "leatherbound" as its based on canvas and I dont seem to be able to select canvas directly.

          Dan Poltawski added a comment -

          Hi Andrew,

          This is to be expected - there is an issue somewhere about this, the drag/drop only works on course pages at the moment. I think that means this can be passed.

          Dan Poltawski added a comment -

          The issue is MDL-32652

          Dan Poltawski added a comment -

          I'm passing this based on your comments Andrew. Please shout if i've got this wrong.

          Dan Poltawski added a comment -

          asko, Дзякуй, ধন্যবাদ, Благодаря, Gràcies, 感谢, 謝謝, Hvala, Díky, Tak, Bedankt, Tänan, متشکریم, Salamat, Kiitokset, Merci, Grazas, Danke, Ευχαριστώ, આભાર, תודה, धन्यवाद, Köszönjük, Takk fyrir, Terima Kasih, Grazie, ありがとうございます, Рахмет, សូមអរគុណ, 감사합니다, gratiās, Pateicamies, Ačiū, Благодарам, Tēnā koa, Kia Ora Rawa Atu, आभारी आहोत, Талархал, Takk, Dziękuję, Obrigado, Mulţumesc, Engraziel, Спасибо, Fa'afetai, Хвала, Hvala, ස්තූතියි, Vďaka, Hvala, Mahadsanid, Thanks, Gracias, Tack, Salamat, நன்றி, నెనరులు, ขอบคุณค่ะ!

          Your work has made it into this weeks Moodle release! There are no gold medals available this week - but millions around the world will benefit. Thank you!


            People

            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: