Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-34612

Convert forum intro format during 1.9->2+ restore

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: 2.4, 2.4.6, 2.5.2
    • Fix Version/s: 2.4.7, 2.5.3
    • Component/s: Forum
    • Labels:
    • Testing Instructions:

      1. As admin/teacher, log into a Moodle 1.9 course
      2. Create a course with a forum.
      3. Save the forum and edit the settings
      4. Note the kind of editor used
      5. Backup the course
      6. Restore the course to a 2.x site and open the course
      7. Edit the settings for the forum
      8. Note the format of the Description editor

      Show
      1. As admin/teacher, log into a Moodle 1.9 course 2. Create a course with a forum. 3. Save the forum and edit the settings 4. Note the kind of editor used 5. Backup the course 6. Restore the course to a 2.x site and open the course 7. Edit the settings for the forum 8. Note the format of the Description editor
    • Affected Branches:
      MOODLE_24_STABLE, MOODLE_25_STABLE
    • Fixed Branches:
      MOODLE_24_STABLE, MOODLE_25_STABLE
    • Pull from Repository:
    • Pull Master Branch:
      MDL-34612-master

      Description

      Same issue as MDL-34586: the intro format isn't converted during a backup/restore scenario, although it is handled properly during an upgrade.

        Gliffy Diagrams

          Attachments

            Issue Links

              Activity

              dmonllao David Monllaó added a comment -

              Hi Charles, it looks great to me

              cfulton Charles Fulton added a comment -

              Rebased against 2.4/2.5.

              nadavkav Nadav Kavalerchik added a comment -

              Important, please code review.

              nadavkav Nadav Kavalerchik added a comment -

              Please move this forward.

              cfulton Charles Fulton added a comment -

              Rebased against master; tweaked some comment styles but no functional changes. Can this be integrated?

              dmonllao David Monllaó added a comment -

              Hi Charles and Nadav,

              It looks good, please backport it to 2.4 and 2.5 or add the pull branches if it is already done. Thanks.

              PD: Charles, I guess you have permissions, but let me know if you can not send to integration

              cfulton Charles Fulton added a comment -

              [~davmon]: branches added. I don't think I have the ability to push to integration; if I do then I don't know how .

              dmonllao David Monllaó added a comment -

              Done, thanks Charles

              stronk7 Eloy Lafuente (stronk7) added a comment -

              The main moodle.git repository has just been updated with latest weekly modifications. You may wish to rebase your PULL branches to simplify history and avoid any possible merge conflicts. This would also make integrator's life easier next week.

              TIA and ciao

              damyon Damyon Wiese added a comment -

              Thanks Charles,

              Looks good to me. Integrated to 24, 25 and master.

              rajeshtaneja Rajesh Taneja added a comment -

              Sorry guys I am failing this for now, as I am only seeing HTML editor only.

              Steps to reproduce:

              1. Disable "Use HTML editor" on Administration ► Appearance ► HTML editor
              2. Create a course with forum in 1.9
              3. Check editor used in forum introduction, should be plain text.
              4. Backup and restore in 2.4
              5. Check forum and it shows html editor.

              looking at backup file forum doesn't have any format information. Not sure what I am missing here.

              Attaching backup for reference.

              damyon Damyon Wiese added a comment -

              The intro format is not stored in the 1.9 backup because there was no field with that name in that version. It checks $CFG->usehtmleditor on restore when converting the backup file format.

              So test should be:

              1. Disable "Use HTML editor" on Administration ► Appearance ► HTML editor
              2. Create a course with forum in 1.9
              3. Check editor used in forum introduction, should be plain text.
              4. Backup in 1.9
              5. Disable "Use HTML editor" on Administration ► Appearance ► HTML editor in 2.4 site
              6. Restore in 2.4
              7. Check forum and it shows plain editor.
              rajeshtaneja Rajesh Taneja added a comment -

              Thanks Damyon,

              Can you please re-open this for testing.

              damyon Damyon Wiese added a comment -

              Done!

              rajeshtaneja Rajesh Taneja added a comment -

              Thanks Charles,

              Works as expected... passing...

              poltawski Dan Poltawski added a comment -

              Hurrah! Thanks for your contribution - this fix is part of Moodle.


                People

                • Votes:
                  2 Vote for this issue
                  Watchers:
                  6 Start watching this issue

                  Dates

                  • Created:
                    Updated:
                    Resolved:
                    Fix Release Date:
                    11/Nov/13