Moodle
  1. Moodle
  2. MDL-34727

Restore UI should use checkboxes for whether to restore userdata

    Details

    • Testing Instructions:
      Hide

      For each of Restore, and Restore from 1.9 in the course settings and in other contexts.

      1. Work all the way through the process, and verify it is not broken.

      2. On the Schema page of the wizard, user data is controlled by check-boxes, not select menus (if it is controllable, otherwise the word No appears).

      Show
      For each of Restore, and Restore from 1.9 in the course settings and in other contexts. 1. Work all the way through the process, and verify it is not broken. 2. On the Schema page of the wizard, user data is controlled by check-boxes, not select menus (if it is controllable, otherwise the word No appears).
    • Affected Branches:
      MOODLE_22_STABLE, MOODLE_23_STABLE
    • Fixed Branches:
      MOODLE_23_STABLE
    • Pull from Repository:
    • Pull Master Branch:
    • Rank:
      43194

      Description

      1. It is more consistent.
      2. It only takes on mouse click to change the setting, not two.
      3. It allows the select all/none links from MDL-32705 to work.

        Issue Links

          Activity

          Hide
          Tim Hunt added a comment -

          To INTEGRATORS, I will let you decide how many different branches you want this on.

          Show
          Tim Hunt added a comment - To INTEGRATORS, I will let you decide how many different branches you want this on.
          Hide
          Tim Hunt added a comment -

          To INTEGRATORS, MDL-34707 and MDL-32705 need to be integrated first. They are on the same branch.

          Show
          Tim Hunt added a comment - To INTEGRATORS, MDL-34707 and MDL-32705 need to be integrated first. They are on the same branch.
          Hide
          Eloy Lafuente (stronk7) added a comment -

          Reopening this as far as MDL-32705 needs more work.

          Also I found some ugly labels being presented (forum_xx_userinfo) and small differences in formatting of the all/none links.

          Ciao

          Show
          Eloy Lafuente (stronk7) added a comment - Reopening this as far as MDL-32705 needs more work. Also I found some ugly labels being presented (forum_xx_userinfo) and small differences in formatting of the all/none links. Ciao
          Hide
          CiBoT added a comment -

          Moving this reopened issue out from current integration. Please, re-submit it for integration once ready.

          Show
          CiBoT added a comment - Moving this reopened issue out from current integration. Please, re-submit it for integration once ready.
          Hide
          Tim Hunt added a comment -

          Eloy, I could re-base this change, so that it could be integrated this week without the MDL-32705 changes.

          Then, next week, we can work on MDL-32705 without worrying about linked changes.

          My patch does not change any labels, so if there is a problem with "some ugly labels being presented", you should file another issue for that (unless I am confused about what you mean).

          Show
          Tim Hunt added a comment - Eloy, I could re-base this change, so that it could be integrated this week without the MDL-32705 changes. Then, next week, we can work on MDL-32705 without worrying about linked changes. My patch does not change any labels, so if there is a problem with "some ugly labels being presented", you should file another issue for that (unless I am confused about what you mean).
          Hide
          Tim Hunt added a comment -

          This has now been re-based onto integration/master, etc, and is ready to integrate without MDL-32705.

          I saw what you meant about the wrong labels, and fixed them.

          Show
          Tim Hunt added a comment - This has now been re-based onto integration/master, etc, and is ready to integrate without MDL-32705 . I saw what you meant about the wrong labels, and fixed them.
          Hide
          Eloy Lafuente (stronk7) added a comment -

          Integrated (23 and master), thanks!

          Note that I've been debating about only introduce this change (improvement) for master, but finally added it also to 23_STABLE, somehow thinking it's young enough to accept safe improvements. And also it's MDL-32705 that is a nice one to be built on top of this.

          But for sure, I don't think this can be backported to 22_STABLE. Strict 100% bugfixes there only.

          Ciao

          Show
          Eloy Lafuente (stronk7) added a comment - Integrated (23 and master), thanks! Note that I've been debating about only introduce this change (improvement) for master, but finally added it also to 23_STABLE, somehow thinking it's young enough to accept safe improvements. And also it's MDL-32705 that is a nice one to be built on top of this. But for sure, I don't think this can be backported to 22_STABLE. Strict 100% bugfixes there only. Ciao
          Hide
          Michael de Raadt added a comment -

          Test result: Success!

          Tested in 2.3 and master with backups from 1.9 and 2.x (with and without user data).

          Show
          Michael de Raadt added a comment - Test result: Success! Tested in 2.3 and master with backups from 1.9 and 2.x (with and without user data).
          Hide
          Eloy Lafuente (stronk7) added a comment -

          Fixed STOP Closed STOP Thanks STOP

          Yay, imagination! Ciao

          Show
          Eloy Lafuente (stronk7) added a comment - Fixed STOP Closed STOP Thanks STOP Yay, imagination! Ciao
          Hide
          Nadav Kavalerchik added a comment -

          @Michael

          I am using an updated Moodle 2.4dev (master branch) version and an updated Moodle 2.3.2 version.
          In both, I did not manage to restore users from a Moodle 1.9 backup file.
          Do you have any instructions (for the testing process) or a sample backup file i can try out?

          Show
          Nadav Kavalerchik added a comment - @Michael I am using an updated Moodle 2.4dev (master branch) version and an updated Moodle 2.3.2 version. In both, I did not manage to restore users from a Moodle 1.9 backup file. Do you have any instructions (for the testing process) or a sample backup file i can try out?
          Hide
          Michael de Raadt added a comment -

          Hi, Nadav.

          Moodle 1.9 user data is not restored into 2.x. The backup converters don't include the code for user data.

          Show
          Michael de Raadt added a comment - Hi, Nadav. Moodle 1.9 user data is not restored into 2.x. The backup converters don't include the code for user data.
          Hide
          Nadav Kavalerchik added a comment -

          @Michael, Thanks (I was not sure where we stand with this)
          Is there an MDL for that?

          Show
          Nadav Kavalerchik added a comment - @Michael, Thanks (I was not sure where we stand with this) Is there an MDL for that?
          Hide
          Michael de Raadt added a comment -

          There is MDL-35308, but I couldn't find any other existing issues. It was on the roadmap at one stage.

          Show
          Michael de Raadt added a comment - There is MDL-35308 , but I couldn't find any other existing issues. It was on the roadmap at one stage.
          Hide
          Nadav Kavalerchik added a comment -

          Thank you Michael. Funny. I also remember Martin said it's on the roadmap.

          Show
          Nadav Kavalerchik added a comment - Thank you Michael. Funny. I also remember Martin said it's on the roadmap.

            People

            • Votes:
              0 Vote for this issue
              Watchers:
              5 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: