Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-34752

Popup Calendar shows wrong month name

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Minor
    • Resolution: Deferred
    • Affects Version/s: 2.3.1
    • Fix Version/s: None
    • Component/s: Calendar
    • Labels:
      None
    • Affected Branches:
      MOODLE_23_STABLE

      Description

      Go to restore a course. Choose restore as new course. When you get to the start date selection, click on the month. The popup box will show up. The grid of dates is correct for the selected month but the name at the top of the box is one month prior. e.g. August's calendar will be names July.

        Gliffy Diagrams

          Attachments

            Issue Links

              Activity

              salvetore Michael de Raadt added a comment -

              Hi, Emma.

              I tried this, but when I went to restore a course, the calendar for the restore had the correct month (mine was from May).

              When was your backup created? Was it around the beginning/end of a month? We have been having some issues with calendars recently that may be related to this.

              emmarichardson Emma Richardson added a comment -

              That's strange - are you on the latest version of Moodle? I used restore as an example but it is happening all over the place. I first noticed it in the attendance module.

              salvetore Michael de Raadt added a comment -

              Hi, Emma.

              Yes, I'm on the bleeding edge.

              I'm thinking MDL-34708 might help resolve this problem. Otherwise it would be good to determine why this is happening on your site.

              emmarichardson Emma Richardson added a comment -

              Not sure where to start. It does seem very similar to 34708 and I have now noticed that the days are off too. I might go in and uninstall some modules that I put in over the weekend but not real sure that is where the problem is. Tempted to wait and see if the fix happens in this week's release before I spend hours trying to track something down that it in fact a bug!

              bfriesen B. Friesen added a comment -

              Note that the month name is the month prior, the date (August 8) should be Wednesday, but there are 31 days in the month as well as the prior month (which means it's not showing the month of July, because the prior month would have 30 days). I also verified that the next month shows 30 days.

              emmarichardson Emma Richardson added a comment -

              Yeah, it's not just me! And yes, it is showing the right grid of numbers for August though the days are off which is 34708.

              rob13 Rob added a comment -

              This also occurs when creating calendar events.

              mspall Michael Spall added a comment -

              We applied the patch for http://tracker.moodle.org/browse/MDL-34708
              https://github.com/nebgor/moodle/commit/201816346877bde81b2673908efd2bb598fdccf5
              and it fixed the issue with the wrong month name and the weeks starting on Saturday for us.

              rjerz Rick Jerz added a comment -

              I saw this problem too (in Moodle 2.3.1+ (Build: 20120802). I was not sure if it had been reported, so I created a tracker item myself (MDL-34847), which now duplicates this tracker item. MDL-34847 can probably be removed (sorry).

              salvetore Michael de Raadt added a comment -

              This appears to be fixed by changes made in MDL-34708. These changes are now available in the latest weekly and should be available in the next major and minor updates.

              If people are still experiencing problems after updating, please comment on this issue.

              temp31415 Travis Cullitan added a comment -

              We were having this problem and upgraded to 2.3.1 build 20120823. I thought it solved the problem because it fixed the calendar for August.Now when I choose September, the date picker is labeled as October. October is labeled as October on the date picker and then November is labeled as December. Is anybody having the same issue?

              emmarichardson Emma Richardson added a comment -

              Same here - very strange because I swear that I checked it when I first upgraded and it was working but not now. Wondering if there was an error in the code they used for the fix.

              emmarichardson Emma Richardson added a comment -

              I created a new tracker issue because this one is closed and behavior is slightly different. MDL-35169

              mspall Michael Spall added a comment -

              After applying the patch, our calender was working correctly until today. It is currently Aug 31, 11:44am MDT. I wonder if it is a boundary condition problem because of the end of the month with 31 days. It looks like if a month has 31 days it displays the correct name and if it has less it displays the next month.

              When I choose the date picker now the month of:
              August 2012 has the name of August 2012
              September 2012 has the name of October 2012
              October 2012 has the name of October 2012
              Nov 12 -> Dec 12
              Dec 12 -> Dec 12
              Jan 13 -> Jan 13
              Feb 12 -> Mar 13
              Mar 13 -> Mar 13
              Apr 13 -> May 13
              May 13 -> May 13
              Jun 13 -> Jul 13
              Jul 13 -> Jul 13
              Aug 13 -> Aug 13

              emmarichardson Emma Richardson added a comment -

              I wondered about that too. I had thought it was every other month but realize that you are correct. It is just the months that have 31 days.

              mspall Michael Spall added a comment -

              I have filed this issue MDL-35171


                People

                • Votes:
                  4 Vote for this issue
                  Watchers:
                  7 Start watching this issue

                  Dates

                  • Created:
                    Updated:
                    Resolved: