Details

    • Type: Sub-task Sub-task
    • Status: Closed
    • Priority: Minor Minor
    • Resolution: Fixed
    • Affects Version/s: 2.2.4, 2.3.1
    • Fix Version/s: 2.4
    • Component/s: Accessibility
    • Labels:
    • Testing Instructions:

      Prerequisites:

      1. Please setup a course with students enrolled so that you are able to interact with the gradebook and verify there are not regressions in functionality.

      Test 1: Grade tree view

      1. Log in as admin
      2. Go to course with few activities
      3. Go to gradebook (Course administration -> grades)
      4. In drop-down select Full view
      5. Inspect all input elements (checkbox and text input) and make sure they all have proper label
      6. Test that all input elements for grading still work

      Test 2: Gradebook

      1. Log in as admin
      2. Go to course with few activities
      3. Go to gradebook (Course administration -> grades)
      4. Click "Turn editing on"
      5. Inspect all input elements (text input) and make sure they all have proper label
      6. Test that all input elements for grading still work

      Note: There is no label set, if you have ajax on and click on grade (which show textinputs)

      Test 3: Assignment grades

      1. Log in as admin
      2. Go to course with assign activity
      3. Click on "View/grade all submissions"
      4. Select "Quick grading"
      5. Make sure all input elements have proper label.
      6. Test that all input elements for grading still work
      Show
      Prerequisites: Please setup a course with students enrolled so that you are able to interact with the gradebook and verify there are not regressions in functionality. Test 1: Grade tree view Log in as admin Go to course with few activities Go to gradebook (Course administration -> grades) In drop-down select Full view Inspect all input elements (checkbox and text input) and make sure they all have proper label Test that all input elements for grading still work Test 2: Gradebook Log in as admin Go to course with few activities Go to gradebook (Course administration -> grades) Click "Turn editing on" Inspect all input elements (text input) and make sure they all have proper label Test that all input elements for grading still work Note: There is no label set, if you have ajax on and click on grade (which show textinputs) Test 3: Assignment grades Log in as admin Go to course with assign activity Click on "View/grade all submissions" Select "Quick grading" Make sure all input elements have proper label. Test that all input elements for grading still work
    • Affected Branches:
      MOODLE_22_STABLE, MOODLE_23_STABLE
    • Fixed Branches:
      MOODLE_24_STABLE
    • Pull Master Branch:
      wip-mdl-34777

      Description

      Fix missing labels in MDL-34559

        Gliffy Diagrams

          Issue Links

            Activity

            Michael de Raadt added a comment -

            Carrying over to the next sprint.

            Rossiani Wijaya added a comment -

            The patch is in working progress, especially for grade/report/grader/module.js file

            Rajesh Taneja added a comment -

            Had a word with Dan, and we agree that, it's not worth making ajax based gradebook accessible, as adding label with current design will make it complicated. Although, with this patch, it is accessible in non-ajax mode and hence we will leave it till there.

            Frédéric Massart added a comment -

            Hi Raj, your patch looks good. Feel free to push for integration but FYI some integrators will prefer the HTML tags to be translated to calls to html_writer. Cheers!

            Rajesh Taneja added a comment -

            Thanks for the review Fred and thanks for pointing htmlwriter usage.

            Had a word with Dan about using htmlwriter and as per discussion, it should go with style of code and not forceful use of htmlwriter.

            Dan Poltawski added a comment -

            The main moodle.git repository has just been updated with latest weekly modifications. You may wish to rebase your PULL branches to simplify history and avoid any possible merge conflicts. This would also make integrator's life easier next week.

            TIA and ciao

            Dan Poltawski added a comment -

            The integration of this issue has been delayed to next week because the integration period is over (Monday, Tuesday) and testing must happen on Wednesday.
            This change to a more rigid timeframe on each integration/testing cycle aims to produce a better and clear separation and organization of tasks for everybody.
            This is a bulk-automated message, so if you want to blame somebody/thing/where, don't do it here (use git instead) :-D :-P
            Apologizes for the inconvenient, this will be integrated next week. Thanks for your collaboration & ciao

            Dan Poltawski added a comment -

            The main moodle.git repository has just been updated with latest weekly modifications. You may wish to rebase your PULL branches to simplify history and avoid any possible merge conflicts. This would also make integrator's life easier next week.

            TIA and ciao

            Eloy Lafuente (stronk7) added a comment -

            The integration of this issue has been delayed to next week because the integration period is over (Monday, Tuesday) and testing must happen on Wednesday.

            This change to a more rigid timeframe on each integration/testing cycle aims to produce a better and clear separation and organization of tasks for everybody.

            This is a bulk-automated message, so if you want to blame somebody/thing/where, don't do it here (use git instead) :-D :-P

            Apologises for the inconvenient, this will be integrated next week. Thanks for your collaboration & ciao

            Dan Poltawski added a comment -

            The integration of this issue has been delayed to next week because the integration period is over (Monday, Tuesday) and testing must happen on Wednesday.
            This change to a more rigid timeframe on each integration/testing cycle aims to produce a better and clear separation and organization of tasks for everybody.
            This is a bulk-automated message, so if you want to blame somebody/thing/where, don't do it here (use git instead) :-D :-P
            Apologizes for the inconvenient, this will be integrated next week. Thanks for your collaboration & ciao

            Aparup Banerjee added a comment -

            The main moodle.git repository has just been updated with latest weekly modifications. You may wish to rebase your PULL branches to simplify history and avoid any possible merge conflicts. This would also make integrator's life easier next week.

            TIA and ciao

            Dan Poltawski added a comment -

            Wow, integrators suck on this issue.

            Dan Poltawski added a comment -

            Hi Raj,

            On behalf of all the integrators, apologies for the amount of time this has been waiting on the integration queue and missed. This was pretty terrible.

            I've integrated it now, on master only as I don't think its helpful to introduce all these strings on the stable branches.

            Rajesh Taneja added a comment -

            Thanks Dan,
            Makes sense to add it for Master only

            Rajesh Taneja added a comment -

            Hello Dan,

            David pointed two problems in the existing patch.
            I have added fix commit on top of it.
            Can you please cherry-pick it on integration.

            Dan Poltawski added a comment -

            Pushed changes.

            David Monllaó added a comment -

            Tested in master. It passes

            Dan Poltawski added a comment -

            Hurray!

            You did it, congratulations! You have on Mojito credit to redeem after the release of Moodle 2.4


              People

              • Votes:
                0 Vote for this issue
                Watchers:
                0 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: