Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-33934 META: Issues with MyMobile theme
  3. MDL-34818

MyMobile theme: Resources folders do not show properly on first access

    Details

    • Type: Sub-task
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 2.2, 2.3.5, 2.4.2, 2.5
    • Fix Version/s: 2.5
    • Component/s: Themes
    • Labels:

      Description

      1-With a mobile using the mobile theme, log into a course that has a folder ressource with several files and subfolders.
      2-Click on the ressource.
      3-The files and folders will show up, but not the tree between them.
      4-Reload the page
      5-The tree now shows properly.

      The tree should properly show up right from the beginning.

        Gliffy Diagrams

        1. FolderNotOk.png
          128 kB
        2. FolderOk.png
          114 kB

          Issue Links

            Activity

            lazydaisy Mary Evans added a comment -

            Thank you Andrew for reporting this. You may find that if you upgrade to Moodle 2.3.1 many of these problems have been addressed.

            leblangi Gilles-Philippe Leblanc added a comment -

            The problem is that the page is loaded ajax mode.
            Indeed, the javascript is not loaded the first time the page is displayed which explains why the rendering is not initialized.

            Just add ".modtype_folder a":

            custom.js

            //calendar and other links that need to be external
                    $('.loginpanel a, .maincalendar .filters a, li.activity.scorm a, div.files a, #page-user-filesPAGE li div a, .maincalendar .bottom a, .section li.url.modtype_url a, .resourcecontent .resourcemediaplugin a, #underfooter .noajax a, .block_mnet_hosts .content a, .block_private_files .content a, a.portfolio-add-link, .modtype_folder a').attr("data-ajax", "false");

            For information, we also add ".loginpanel a" because we use CAS authentication method and it did not work without this addition.

            epsd John Stabinger added a comment -

            I suspected as much. I will get this in ASAP. Thanks!

            epsd John Stabinger added a comment -
            stronk7 Eloy Lafuente (stronk7) added a comment -

            Integrated (23, 24 & master), thanks!

            abgreeve Adrian Greeve added a comment -

            This worked fine on the master integration branch, but did not on 2.3 and 2.4.
            Further investigation is required.

            lazydaisy Mary Evans added a comment -

            Can you ensure Master gets the fix then?
            Thanks

            lazydaisy Mary Evans added a comment - - edited

            Adrian, I have just realised that fixes for Moodle 2.3 and 2.4 in MDL-38422 should have been done first, that's why this patch is not working in those branches.

            I'll create a new tracker to deal with those stable branches for next weeks Pull.

            Many thanks

            stronk7 Eloy Lafuente (stronk7) added a comment - - edited

            Oh, Mary, why were you editing the fields here (cleaning the 23 and 24 branches/diffs) and editing the fixfor versions.

            I was getting crazy here because I commented above that this had landed for 23 and 24 but wasn't unable to find any information in the issue about them. Just looking git history revealed that this had landed for 23 and 24.

            So please, once integrated, avoid editing that sort of information because it can lead to uncontrolled changes/testing. TIA!

            Back to the issue, from tester comments:

            1) this is supposed to be working for master.
            2) this is not working for 23 and 24.

            So we have 2 options:

            A) We revert this for all branches and reopen it for a new attempt when all the dependencies are meet (I'd add one "is blocked by MDL-38422" link to make everybody aware of the situation).

            B) We revert this for 23 and 24, create a followup issue for those branches and pass this only for master. Also being "is blocked by MDL-38422", of course.

            Any of them are ok for me, any preference?

            Ciao

            lazydaisy Mary Evans added a comment - - edited

            Option B - and sorry for confusion...I just get carried away sometimes.
            Also...I assumed this would happens so created MDL-38460 earlier today.

            stronk7 Eloy Lafuente (stronk7) added a comment -

            Oki, thanks. Reverting the 23 and 24 branches, keeping this as master only and passing as tested (on behalf of Andrew comments).

            Ciao

            stronk7 Eloy Lafuente (stronk7) added a comment -

            All done, passing. Ciao

            lazydaisy Mary Evans added a comment -

            Gracias y buenas noches!

            stronk7 Eloy Lafuente (stronk7) added a comment -

            This issue has been integrated upstream and is now available both via git and cvs (and in some hours, via mirrors and downloads).

            Thanks!

            PS: Yay, legacy template messages. Yes, you're ok, we don't have CVS anymore!


              People

              • Votes:
                0 Vote for this issue
                Watchers:
                4 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:
                  Fix Release Date:
                  14/May/13