Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-34941

core_course_external_testcase::test_create_courses => start date timestamp is out of range

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: 2.3.1, 2.4
    • Fix Version/s: 2.3.2
    • Component/s: Web Services
    • Labels:

      Description

      core_course_external_testcase::test_create_courses => start date timestamp is out of range

        Gliffy Diagrams

          Attachments

            Issue Links

              Activity

              jerome Jérôme Mouneyrac added a comment -

              Submitting for integration without peer-review as it's simple and as it breaks PHPUnit test on 32bits system.

              timhunt Tim Hunt added a comment -

              Since I was the one who originally reported the problem, and can reproduce it, I have tested this fix, and can confirm that it works. So, integrators, you may wish to move this directly to the Tested state.

              I have also peer-reviewed the change, and I give it my +1.

              stronk7 Eloy Lafuente (stronk7) added a comment -

              Integrated, thanks (23 & master).

              stronk7 Eloy Lafuente (stronk7) added a comment -

              Passing based on Tim's tests, thanks!

              stronk7 Eloy Lafuente (stronk7) added a comment -

              YEAR!*

              CAF*, TOT!*

              • Your effort amazingly resulted. (unbelievable :-P)
              • Closing as fixed.
              • Tons of thanks.

                People

                • Votes:
                  0 Vote for this issue
                  Watchers:
                  1 Start watching this issue

                  Dates

                  • Created:
                    Updated:
                    Resolved:
                    Fix Release Date:
                    10/Sep/12