Moodle
  1. Moodle
  2. MDL-34985

Default parent for adding new grade category inconsistent

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Minor Minor
    • Resolution: Fixed
    • Affects Version/s: 2.2.4, 2.3.1
    • Fix Version/s: 2.2.5, 2.3.2
    • Component/s: Gradebook
    • Labels:
    • Database:
      PostgreSQL
    • Testing Instructions:

      In postgres and mysql

      1. Create a course
      2. Go into gradebook->full view
      3. Click add category
      4. Add a Category
      5. Click add category again
      6. At the bottom dropdown, the course grade category should be default, NOT the one you added manually.
      Show
      In postgres and mysql Create a course Go into gradebook->full view Click add category Add a Category Click add category again At the bottom dropdown, the course grade category should be default, NOT the one you added manually.
    • Affected Branches:
      MOODLE_22_STABLE, MOODLE_23_STABLE
    • Fixed Branches:
      MOODLE_22_STABLE, MOODLE_23_STABLE
    • Pull Master Branch:

      Description

      When in the Gradebook 'Full View', when you click Add Category, the behaviour can be inconsistent depending on your database. It defaults to whatever the top category is, but the categories are returned in DB order (unordered). In MySQL this will generally mean that the course category will be first, but in Postgres, order is not 'known', and in our case it means the most recently added category is at top.

        Gliffy Diagrams

          Activity

          Eric Merrill added a comment -

          Turns out the default is already being computed, just not applied to the setting.

          Eric Merrill added a comment -

          I believe this is ready for integration pending a review.

          Thanks

          Andrew Davis added a comment -

          Looks good to me. Submit for integration whenever you are ready.

          Eric Merrill added a comment -

          I don't have that ability yet (I need to bug someone about that ), so if you could submit it, that would be great.

          Helen Foster added a comment -

          Submitting for integration review as requested by Eric.

          Eloy Lafuente (stronk7) added a comment -

          The main moodle.git repository has just been updated with latest weekly modifications. You may wish to rebase your PULL branches to simplify history and avoid any possible merge conflicts. This would also make integrator's life easier next week.

          TIA and ciao

          Eloy Lafuente (stronk7) added a comment -

          Integrated (22, 23 & master), thanks!

          Eloy Lafuente (stronk7) added a comment -

          Passing, I've tried both with mysql and postgres before and after and I was not able to reproduce the problem, but checked that now the course category is explicitly "selected", so any lack of order should not be a problem anymore.

          Thanks!

          Eloy Lafuente (stronk7) added a comment -

          Many thanks for the hard work.

          These changes have been spread upstream and are already available in the git and cvs repositories.

          Ciao


            People

            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: