Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-34993

Default mark 1 when editing MC questions should not be displayed as 1.0000000

    XMLWordPrintable

Details

    • Improvement
    • Status: Closed
    • Minor
    • Resolution: Fixed
    • 2.2.2, 2.3.1, 2.4
    • 2.2.5, 2.3.2
    • Questions
    • None
    • MOODLE_22_STABLE, MOODLE_23_STABLE, MOODLE_24_STABLE
    • MOODLE_22_STABLE, MOODLE_23_STABLE
    • Hide

      1. Create a question.

      2. Edit the question again. Make sure the Default mark field contains 1, and no 1.0000000.

      3. Change the default mark to 1.2345678, and make sure that fits in the box.

      Show
      1. Create a question. 2. Edit the question again. Make sure the Default mark field contains 1, and no 1.0000000. 3. Change the default mark to 1.2345678, and make sure that fits in the box.

    Description

      When editing a multichoice question the default mark 1 is displayed as 1.0000000 (see screenshot)
      This is due to storing the mark as NUMBER(12,7)in the DB. It would be nice if such a default mark would
      be displayed as '1' in the future.
      Tim Hunt knows the issue and suggests that "You just need to add +0 in the code that passes the value to the form.".

      Attachments

        Activity

          People

            timhunt Tim Hunt
            jzimmer Juergen Zimmer
            Eloy Lafuente (stronk7) Eloy Lafuente (stronk7)
            Adrian Greeve Adrian Greeve
            Safat Shahin, Tim Hunt, Amaia Anabitarte, Bas Brands, Carlos Escobedo, Ferran Recio, Ilya Tregubov, Kevin Percy, Laurent David, Mathew May, Mihail Geshoski, Raquel Ortega, Sabina Abellan, Sander Bangma, Sara Arjona (@sarjona), Shamim Rezaie
            Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

              Created:
              Updated:
              Resolved:
              10/Sep/12