Moodle
  1. Moodle
  2. MDL-35007

Missing rule BOOKCHAPTER restoring a 1.9 backup

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 2.3.1
    • Fix Version/s: 2.3.3
    • Component/s: Book
    • Labels:
    • Testing Instructions:
      1. Run upgrades on all branches before proceeding with the testing
      2. install book module on your 1.9 install http://moodle.org/plugins/pluginversions.php?plugin=mod_book
      3. create a book instance
      4. create a lesson and add a question page to the lesson, add a link to the book chapter (not book index, must have chapterid in url) in the question description
      5. backup the course with all defaults
      6. Restore the course as "new course" in 2.3/master
      7. Go to the lesson and make sure the link to book module now points to the restored book module in the course and doesnt say something like $@BOOKCHAPTER*7@$
      Show
      Run upgrades on all branches before proceeding with the testing install book module on your 1.9 install http://moodle.org/plugins/pluginversions.php?plugin=mod_book create a book instance create a lesson and add a question page to the lesson, add a link to the book chapter (not book index, must have chapterid in url) in the question description backup the course with all defaults Restore the course as "new course" in 2.3/master Go to the lesson and make sure the link to book module now points to the restored book module in the course and doesnt say something like $@BOOKCHAPTER*7@$
    • Affected Branches:
      MOODLE_23_STABLE
    • Fixed Branches:
      MOODLE_23_STABLE
    • Pull Master Branch:
      MDL-35007-master
    • Rank:
      43607

      Description

      The problem is that we do not handle BOOKCHAPTER restore_decode_rule rules that are generated in a Moodle 1.9 backup when there are links to book chapters.

      Replication steps:

      1. install book module in Moodle 1.9 (install http://moodle.org/plugins/pluginversions.php?plugin=mod_book)
      2. create a book instance
      3. create a Web page resource
      4. in the label add a link to the book chapter
      5. backup the course with all defaults
      6. Restore the course as "new course" in 2.3
      7. check the restored Page resource

      Expected result: the link to book module should point to the restored book chapter

      Actual result: the link is replace with something like $@BOOKCHAPTER*7@2$

        Issue Links

          Activity

          Ankit Agarwal added a comment -

          Requesting a review

          Thanks

          Rossiani Wijaya added a comment -

          This looks good Ankit.

          +1 for integration.

          Ankit Agarwal added a comment -

          Thanks for the review Rosie.
          sending for integration!

          Eloy Lafuente (stronk7) added a comment -

          The main moodle.git repository has just been updated with latest weekly modifications. You may wish to rebase your PULL branches to simplify history and avoid any possible merge conflicts. This would also make integrator's life easier next week.

          TIA and ciao

          Ankit Agarwal added a comment -

          rebased

          Thanks

          Sam Hemelryk added a comment -

          Thanks Ankit, this has been integrated now

          Frédéric Massart added a comment -

          All good. Thanks!

          Eloy Lafuente (stronk7) added a comment -

          Gutta cavat lapidem, non vi sed saepe cadendo - Ovidio

          This issue has been integrated upstream and is now available both via git and cvs (and in some hours, via mirrors and downloads).

          Thanks!


            People

            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: