Moodle
  1. Moodle
  2. MDL-35187

Change page layout for GROUP from 'standard' to 'admin'

    Details

    • Type: Improvement Improvement
    • Status: Closed
    • Priority: Minor Minor
    • Resolution: Fixed
    • Affects Version/s: 2.3.1
    • Fix Version/s: 2.4
    • Component/s: Groups
    • Labels:
    • Testing Instructions:
      1. Login as admin and select Standard theme either from theme selector or by URL whichever is the easiest
      2. Click the 'Create group' button in Settings > Course administration > Users > Groups
      3. Add a group name and optional description (displayed above the list of group members on the participants page), enrolment key and picture (displayed on the participants page and next to forum posts).
      4. Click the 'Save changes' button
      5. Select the group to which you want to add participants, then click the 'Add/remove users button
      6. In the "Potential members" list, select the users you want to add to the group.
      7. Click the Add button to add the users to the group.
      8. In all of the above instructions the page should be in a pre-side only layout (2 columns - left and middle)and NOT three columns.
      Show
      Login as admin and select Standard theme either from theme selector or by URL whichever is the easiest Click the 'Create group' button in Settings > Course administration > Users > Groups Add a group name and optional description (displayed above the list of group members on the participants page), enrolment key and picture (displayed on the participants page and next to forum posts). Click the 'Save changes' button Select the group to which you want to add participants, then click the 'Add/remove users button In the "Potential members" list, select the users you want to add to the group. Click the Add button to add the users to the group. In all of the above instructions the page should be in a pre-side only layout (2 columns - left and middle)and NOT three columns.
    • Affected Branches:
      MOODLE_23_STABLE
    • Fixed Branches:
      MOODLE_24_STABLE
    • Pull Master Branch:
    • Rank:
      43824

      Description

      Discovered while testing: When creating/editing Groups, Admins need lots of space. Currently Groups is set with 'standard' layout which allows side blocks, both left and right, which take up valuable space.
      It would make better sense to change the page layout to 'Admin' thus freeing up space on the right.

        Activity

        Mary Evans added a comment -

        Michael, could you Peer Review MDL-35187 as a proposed change to the layout type for Groups from 'standard' to 'admin'? Admin being a side-pre-only layout gives more space on a page when creating/editing Groups.

        Michael de Raadt added a comment -

        Hi, Mary.

        That seems sensible for themes such as Overlay.

        The code change is fine.

        You will need to add testing instructions to this issue before pushing to integration.

        I considered if this constitutes a user interface change, requiring docs_required and ui_change labels, but I don't think it is significant enough to inform users about.

        Don't forget to set a Fix Version when you triage something. It should be Stable backlog or Dev backlog until it is sent to integration.

        Michael de Raadt added a comment -

        Actually, I noted you had STABLE backlog on the Affects version. This should be a released version (unless the issue is about a new feature).

        Mary Evans added a comment - - edited

        Thanks Michael,

        Sorry for taking so long to get back to you, but have been busy and forgot to.

        Thank you for looking at this, and for your comments.

        I'll put it up for Integration Review and see how it goes, although I was only thinking of changing this in Master (Moodle 2.4) rather than for STABLE Backlog. What do you think?

        Michael de Raadt added a comment -

        Yes, probably a master only change.

        Dan Poltawski added a comment -

        The main moodle.git repository has just been updated with latest weekly modifications. You may wish to rebase your PULL branches to simplify history and avoid any possible merge conflicts. This would also make integrator's life easier next week.

        TIA and ciao

        Dan Poltawski added a comment -

        Hi Mary,

        We need testing instructions for this change.

        Dan Poltawski added a comment -

        I've integrated this, in confidence that testing instructions will arrive.

        Mary Evans added a comment -

        Instructions added.

        Mary Evans added a comment -

        @DanP I've also rebased this branch too...hope that was OK at this late stage?

        David Monllaó added a comment -

        Hi Mary, I'm following the testing instructions, using the standard theme and being in a course with blocks on both sides.

        • When I go to course administration > users -> groups (group/index.php) the page is split in 2 columns, with and without the patch, "pagelayout*" body class changes to pagelayout-admin and if I enable editing mode I can only add blocks to the pre side, so the patch works as expected.
        • When I create a new group (group/group.php) I can only see the main column
        • When I'm editing the group members I see pre and main columns, but enabling the editing mode I can add blocks to post side.

        Looking at the patch it seems that it only modifies the behaviour of group/index.php, but other pages involved in the testing instructions uses different layouts, group/group.php (adding a new group) uses base (default) pagelayout, group/members.php (adding/removing members of the group) uses standard pagelayout. Other groups pages (autocreate groups, adding groupings...) also uses different pagelayouts.

        Mary Evans added a comment -

        The main reason I suggested this change in layout, was because I found the original layout too restricting when adding users to the group, so it was only intended for adding and editing. I assumed that the page would be the same throughout the process, as I am not that familiar with groups to tell the truth.

        David Monllaó added a comment -

        Thanks for the quick reply Mary; according to your comment I've added a quick fix to also change the group members pagelayout to admin

        https://github.com/dmonllao/moodle/commit/d91750bc5a21fed31a5cce13cebda562adca0f47

        Dan Poltawski added a comment -

        I've pulled this fix in, for the interests of expediency.

        David Monllaó added a comment -
        Mary Evans added a comment -

        Cool! Thanks for that!

        Eloy Lafuente (stronk7) added a comment -

        Closing as fixed, many thanks for your awesome collaboration.


          People

          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: