Moodle
  1. Moodle
  2. MDL-35231

Assignment 2.3 + Serenity theme = unsuable actions menu on grading

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Minor Minor
    • Resolution: Fixed
    • Affects Version/s: 2.2.5, 2.3.2, 2.4
    • Fix Version/s: 2.2.6, 2.3.3
    • Component/s: Themes
    • Labels:
    • Testing Instructions:

      NOTE TO TESTER: This TEST requires a Custom Menu (Appearance/Theme settings) to be set-up prior to testing. Also need to either Purge all caches (Development/Purge all caches)or enable Theme Designer Mode (Appearance/Theme settings) to see changes when testing.
      ----------------------

      1. Login as Admin and select Serenity theme
      2. Go to any course and create an assignment, choose "save and display"
      3. Next follow "View/grade all submissions" link.
      4. In the grader table, click on any icon in the "Edit" column (it has "action" tooltip).
      5. TEST to see that the 'pop-out' menu item list is readable (black on white with blue hover action)
      6. TEST the main menu that main titles are white on a darkish brown background, and display a white dropdown with black text and a mink coloured background hover action.
        End Test
      Show
      NOTE TO TESTER: This TEST requires a Custom Menu (Appearance/Theme settings) to be set-up prior to testing. Also need to either Purge all caches (Development/Purge all caches)or enable Theme Designer Mode (Appearance/Theme settings) to see changes when testing. ---------------------- Login as Admin and select Serenity theme Go to any course and create an assignment, choose "save and display" Next follow "View/grade all submissions" link. In the grader table, click on any icon in the "Edit" column (it has "action" tooltip). TEST to see that the 'pop-out' menu item list is readable (black on white with blue hover action) TEST the main menu that main titles are white on a darkish brown background, and display a white dropdown with black text and a mink coloured background hover action. End Test
    • Workaround:

      Use attached core.css to replace theme/serenity/style/core.css

      Show
      Use attached core.css to replace theme/serenity/style/core.css
    • Affected Branches:
      MOODLE_22_STABLE, MOODLE_23_STABLE, MOODLE_24_STABLE
    • Fixed Branches:
      MOODLE_22_STABLE, MOODLE_23_STABLE
    • Pull Master Branch:
      MDL-35231_master
    • Rank:
      43879

      Description

      When using assignment 2.3 and serenity theme (in the core), it seems that action menu in the grading table is printed white on white, so it's impossible to see it. Only selected string is seen.

      Hope to attach screenshot from Google Chrome 21.0.1180.89 m, last version.

      1. core.css
        6 kB
        Mary Evans
      1. screenshot-1.jpg
        20 kB

        Issue Links

          Activity

          Oleg Sychev added a comment -

          A screenshot of how it looks.

          To reproduce, choose serenity theme, create new assignment and and post an submission to it, than log in as a teacher and go to grading.

          Oleg Sychev added a comment -

          Helen, this issue doesn't receive any attention for too long. Could you assign it to relevant people?

          Mary Evans added a comment -

          This looks like theme styling problem rather than something to do with assignments. I'll tst it out and try and get fixed ASAP.
          Thanks for letting me know about this.

          Mary Evans added a comment -

          Oleg, I am having problems trying to replicate this problem, this is probably to do with the fact I don't know how to get to the page you say the grader is white on white. At the moment the grader looks OK and with black font on white background.

          If you could give me instruction how to get to the page you are talking about that would be very helpful.
          Thank you

          Mary

          Oleg Sychev added a comment -

          Mary, I successfully reproduced problem on qa.moodle.net

          Login as a teacher and change you preffered theme to Serenity.

          Go to CF101 course and create an assignment there, choose "save and display"
          Now follow "View/grade all submissions" link.
          In the table, click on any icon in the "Edit" column (it has "action" tooltip).
          There is menu to the right now, but you can not see it due to the bug (try different theme). Navigate mouse to the right until it gets over "Grade", then you could navigate down to see other menu items.

          http://qa.moodle.net/mod/assign/view.php?id=281&action=grading
          (you id may be different of course)
          If you hurry, you may get link working...

          Mary Evans added a comment -

          This theme needs to be updated as the main menu CSS code is badly written and so over writes the edit action in the Assignment grade book.

          I'll work on it and get it fixed so should be fixed and in the next weekly Moodle 2.3.x download.

          I'll upload a copy of the amended core.css so you can see the changes. You can download it and use the file instead of your current one, untill the official one is released.

          Thanks again for telling me in the forum about this.

          Mary

          Mary Evans added a comment -

          Attached amended core.css

          Mary Evans added a comment -

          Fix complete, just Test Instructions to complete.

          Helen Foster added a comment -

          Oleg and Mary, many thanks for your work on this issue - nice reading your comments and seeing the collaboration between reporter and assignee.

          Oleg Sychev added a comment -

          Mary, I uploaded amended core.css to our site and it seems to work. Thanks for the fix.

          I would add to testing instructions a note about purging caches after changing css files. Otherwise it may use old styles and won't work - this was the case for my site.

          Mary Evans added a comment -

          Thanks Oleg, I have amended the Test Instructions accordingly.

          Aparup Banerjee added a comment -

          Hi Mary, i was wondering if we should test for any other possible regressions here along with these changes. (but i've to look into this deeper to know specifically what so review still in progress )

          Mary Evans added a comment -

          There is only 2.2 to worry about as we ain't fixing 2.1 anymore.
          You could cherry-pick this to MOODLE_22_STABLE.

          Aparup Banerjee added a comment -

          Ok thats integrated into master, 23 and 22.

          Aparup Banerjee added a comment -

          Hi, i was testing across more branches and:
          22 and master are fine.. for some reason 23 doesn't show the custom menu!

          23 and master show the edit menu with nice looking hover colours fine. NA in 22.

          so just need to fix up in 23 the custom menu not showing. (i had the same custom menu through out the test)

          Mary Evans added a comment -

          @Aparup

          I'm just testing in 2.3.2 (latest release) and find no problems with custommenu. All working perfectly well.

          Could this be local to your computer set-up/configuration?

          Mary Evans added a comment -

          I bet you forget to ADD custom menu items in Theme setting in Moodle 2.3 LOL

          Rajesh Taneja added a comment -

          Hello Everyone,

          Apu asked me to test this on integration 23 and I can't see custom menu as well.

          Aparup Banerjee added a comment - - edited

          Hi, ok i've tested locally with a revert of the patch to eliminate causes and the menu still isn't showing up for me in 23 (integration without the patch).

          This means the patch is fine so i'm guessing there is a cause external to this MDL.

          based on above this patch should actually pass (also its passing on other branches)

          so passing

          ps: opening another follow up to this : MDL-35986

          Mary Evans added a comment -

          Just updated MDL-35986 - seems there is a regression in Serenity/Canvas themes in MOODLE_23_STABLE
          all my fault apparently.

          Eloy Lafuente (stronk7) added a comment -

          From somewhere within the clouds...

          Congrats, this has been sent upstream and is now part of Moodle (your favorite LMS platform). Many thanks for your awesome collaboration!

          Ciao


            People

            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: