Details

    • Type: Sub-task
    • Status: Closed
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: 2.2.5, 2.3.1, 2.4
    • Fix Version/s: 2.2.6, 2.3.3
    • Component/s: Themes
    • Labels:
    • Testing Instructions:
      1. Install an Hebrew (RTL) language pack, and switch to Hebrew
      2. Navigate to any course
      3. Under Course Setting menu, Open "Question Bank" menu and click "Categories"
        (Home / ► Courses / ► SomeCourse / ► Question bank / ► Categories)
      4. Add several categories and subcategories, for testing.
        See the issues listed above (Description section and attached screen capture images)
      5. Apply the patch
      6. Reload the page and verify the issue is solved (Make sure "Theme Designer" mode is ON, so changes are applied)
      Show
      Install an Hebrew (RTL) language pack, and switch to Hebrew Navigate to any course Under Course Setting menu, Open "Question Bank" menu and click "Categories" (Home / ► Courses / ► SomeCourse / ► Question bank / ► Categories) Add several categories and subcategories, for testing. See the issues listed above (Description section and attached screen capture images) Apply the patch Reload the page and verify the issue is solved (Make sure "Theme Designer" mode is ON, so changes are applied)
    • Affected Branches:
      MOODLE_22_STABLE, MOODLE_23_STABLE, MOODLE_24_STABLE
    • Fixed Branches:
      MOODLE_22_STABLE, MOODLE_23_STABLE
    • Pull from Repository:
    • Pull Master Branch:
      WIP-MDL-35246

      Description

      Invert all action arrows in Question Bank categories management, when in RTL mode
      (Home / ► Courses / ► SomeCourse / ► Question bank / ► Categories)

        Gliffy Diagrams

          Activity

          stronk7 Eloy Lafuente (stronk7) added a comment -

          Integrated (22, 23 & master), thanks!

          stronk7 Eloy Lafuente (stronk7) added a comment -

          Passing, arrows now point to the correct side in RTL mode.

          Side note: Perhaps the "indentation" is a bit small in RTL mode. It exists but smaller than the LTR one.

          poltawski Dan Poltawski added a comment -

          Congratulations, you've done it!

          Nf n erjneq sbe fhpprfshy vagrtengvba vagb guvf jrrxf eryrnfr, V pna abj qvfpybfr gb lbh gur rkvfgnapr bs shapgvba fge_ebg13(), gb tb va lbhe gbbyxvg nybat jvgu uggc://cuc.arg/znahny/ra/shapgvba.tmtrgff.cuc

          Cyrnfr qb abg nyybj guvf vasbezngvba gb cnff shegure.


            People

            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:
                Fix Release Date:
                12/Nov/12