Moodle
  1. Moodle
  2. MDL-35264

Text input element not visible in chat server daemon method

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Minor Minor
    • Resolution: Fixed
    • Affects Version/s: 2.2, 2.2.5, 2.3.2, 2.4
    • Fix Version/s: 2.2.6, 2.3.3
    • Component/s: Chat
    • Labels:
    • Testing Instructions:

      This issue is blocked by MDL-27398 so must be tested with MDL-27398 integrated and with different browsers and themes; the previous problem is not reproducible in all the themes, if you are interested in reproduce it try with the standard theme

      1. Login as an admin user
      2. Go to admin tree -> Plugins -> Activity modules -> Chat, and select chat daemon as chat_method
      3. Go to a course and create a chat activity
      4. Go to the chat instance and click "Click here to enter the chat now"
      5. In the lower-left part of the opened popup you SHOULD see a text input element and you SHOULD be able to add messages
      Show
      This issue is blocked by MDL-27398 so must be tested with MDL-27398 integrated and with different browsers and themes; the previous problem is not reproducible in all the themes, if you are interested in reproduce it try with the standard theme Login as an admin user Go to admin tree -> Plugins -> Activity modules -> Chat, and select chat daemon as chat_method Go to a course and create a chat activity Go to the chat instance and click "Click here to enter the chat now" In the lower-left part of the opened popup you SHOULD see a text input element and you SHOULD be able to add messages
    • Affected Branches:
      MOODLE_22_STABLE, MOODLE_23_STABLE, MOODLE_24_STABLE
    • Fixed Branches:
      MOODLE_22_STABLE, MOODLE_23_STABLE
    • Pull from Repository:
    • Pull Master Branch:
      MDL-35264_master

      Description

      The chat server daemon method divides the chat popup in 3 frames, the lower one allows users to add messages, but the available space is limited to 50px and the moodle breadcrumb occupies most of the space, hiding the text input element.

        Gliffy Diagrams

          Issue Links

            Activity

            David Monllaó added a comment -

            Changing the page layout to embedded in the chat input frame, submitting for peer review

            Rossiani Wijaya added a comment -

            This looks good David.

            +1 for integration.

            Rossiani Wijaya added a comment -

            additional note:

            Could you add an extra step to use standard theme for the test instruction?

            Thank you.

            David Monllaó added a comment -

            Thanks for the comments Rossie, I've added a little explication. Submitting for integration

            Eloy Lafuente (stronk7) added a comment -

            The main moodle.git repository has just been updated with latest weekly modifications. You may wish to rebase your PULL branches to simplify history and avoid any possible merge conflicts. This would also make integrator's life easier next week.

            TIA and ciao

            David Monllaó added a comment -

            Rebased

            Aparup Banerjee added a comment -

            thanks, thats been integrated into 22, 23 and master for testing.

            Ankit Agarwal added a comment - - edited

            Failing this because of MDL-35384

            Using:- Firefox and Anamoly theme
            Thanks

            David Monllaó added a comment -

            Thanks Ankit

            I've added a branch with a fix:
            git://github.com/dmonllao/moodle.git MDL-35264_fix

            Commit:
            https://github.com/dmonllao/moodle/commit/1fa2dfbcb61921f3573559fbf25c648e1f1f1f7d

            David Monllaó added a comment -

            It can be also applied to 22 and 23

            Aparup Banerjee added a comment -

            thanks for picking that up and fixing it guys, i've pushed that up into 22, 23 and master too now.

            Ankit Agarwal added a comment -

            Still a portion of the input text field is not visible, although it is better than it was before. I guess that can be taken care of in MDL-35384. Passing this as Aparup suggested.

            Thanks

            Eloy Lafuente (stronk7) added a comment -

            Gutta cavat lapidem, non vi sed saepe cadendo - Ovidio

            This issue has been integrated upstream and is now available both via git and cvs (and in some hours, via mirrors and downloads).

            Thanks!


              People

              • Votes:
                0 Vote for this issue
                Watchers:
                1 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: