Moodle
  1. Moodle
  2. MDL-35581 META: tasks related to RTL theme fixes before 2.4 freeze (Week 39)
  3. MDL-35481

Invert "search option" listbox "open" arrow, when in RTL mode (page: manual user course registration )

    Details

    • Type: Sub-task Sub-task
    • Status: Closed
    • Priority: Minor Minor
    • Resolution: Fixed
    • Affects Version/s: 2.3, 2.4
    • Fix Version/s: 2.3.3
    • Component/s: Themes
    • Labels:
    • Testing Instructions:
      1. Install an Hebrew (RTL) language pack, and switch to Hebrew
      2. Navigate to:
        1. Course setting, manual user course registration page (moodle/enrol/manual/manage.php?enrolid=SomeCourseID)
        2. Home / ► Courses / ► TestCourse / ► Users / ► Enrolled users
        3. Home / ► My profile / ► Blogs / ► View all of my entries
          See the issues listed above (Description section and in attached screen capture images)
      3. Apply the patch
      4. Reload the page and verify the issue is solved (Make sure "Theme Designer" mode is ON, so changes are applied)
      Show
      Install an Hebrew (RTL) language pack, and switch to Hebrew Navigate to: Course setting, manual user course registration page (moodle/enrol/manual/manage.php?enrolid=SomeCourseID) Home / ► Courses / ► TestCourse / ► Users / ► Enrolled users Home / ► My profile / ► Blogs / ► View all of my entries See the issues listed above (Description section and in attached screen capture images) Apply the patch Reload the page and verify the issue is solved (Make sure "Theme Designer" mode is ON, so changes are applied)
    • Affected Branches:
      MOODLE_23_STABLE, MOODLE_24_STABLE
    • Fixed Branches:
      MOODLE_23_STABLE
    • Pull from Repository:
    • Pull Master Branch:
      WIP-MDL-35481

      Description

      1. Invert "Search Options" listbox "open" arrow, when in RTL mode (Course setting, manual user course registration page )
      2. Invert "Enrolled Options" listbox "open" arrow (Home / ► Courses / ► TestCourse / ► Users / ► Enrolled users)
      3. Invert "View Comments" listbox "open" arrow (Home / ► My profile / ► Blogs / ► View all of my entries)

      Minor UI update

        Gliffy Diagrams

          Activity

          Eloy Lafuente (stronk7) added a comment -

          Integrated (23 & master), thanks!

          Eloy Lafuente (stronk7) added a comment -

          Passing as far as the 3 places continue working under LTR ok and also, under RTL, the expand/collapse triangles are pointing to the left.

          Side note: Sometimes the triangle is on the right (of the text), sometimes it is on the left. Always pointing to the left (correct) but before/after the label.

          Dan Poltawski added a comment -

          Congratulations, you've done it!

          Nf n erjneq sbe fhpprfshy vagrtengvba vagb guvf jrrxf eryrnfr, V pna abj qvfpybfr gb lbh gur rkvfgnapr bs shapgvba fge_ebg13(), gb tb va lbhe gbbyxvg nybat jvgu uggc://cuc.arg/znahny/ra/shapgvba.tmtrgff.cuc

          Cyrnfr qb abg nyybj guvf vasbezngvba gb cnff shegure.


            People

            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: