Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-35489

Notice on Browse Users page when using an empty filter

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 2.2.5, 2.3.2
    • Fix Version/s: 2.2.6, 2.3.3
    • Component/s: Administration
    • Labels:
    • Testing Instructions:
      Hide
      1. Turn on debugging.
      2. Go to Site Administration > Users > Browse list of users.
      3. Choose "is empty" for one of the filters (like email).
      4. Add the filter and make sure you don't see any notice.
        3 Try "is empty" for other filters and make sure you don't see notice.
      Show
      Turn on debugging. Go to Site Administration > Users > Browse list of users. Choose "is empty" for one of the filters (like email). Add the filter and make sure you don't see any notice. 3 Try "is empty" for other filters and make sure you don't see notice.
    • Affected Branches:
      MOODLE_22_STABLE, MOODLE_23_STABLE
    • Fixed Branches:
      MOODLE_22_STABLE, MOODLE_23_STABLE
    • Pull Master Branch:
      wip-mdl-35489

      Description

      Steps to reproduce:

      1. Turn on debugging.
      2. Go to Site Administration > Browse list of users.
      3. Choose "empty" for one of the filters (like email).
      4. Add the filter.

      You'll get a notice like this: Notice: Undefined property: stdClass::$email in wwwroot/user/filters/text.php on line 65

        Gliffy Diagrams

          Attachments

            Activity

              People

              • Votes:
                0 Vote for this issue
                Watchers:
                1 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:
                  Fix Release Date:
                  12/Nov/12