Details

    • Type: Task
    • Status: Closed
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: 2.4
    • Fix Version/s: 2.4
    • Component/s: Libraries
    • Labels:
    • Testing Instructions:

      usual YUI testing after new version import, open JS console and visit moodle pages that use YUI:

      • course page edit mode
      • navigation
      • file picker
      • ims and scorm
      • user selection forms - groups, roles, cohorts, etc.
      • gradebook
      Show
      usual YUI testing after new version import, open JS console and visit moodle pages that use YUI: course page edit mode navigation file picker ims and scorm user selection forms - groups, roles, cohorts, etc. gradebook
    • Affected Branches:
      MOODLE_24_STABLE
    • Fixed Branches:
      MOODLE_24_STABLE
    • Pull from Repository:
    • Pull Master Branch:
      w39_MDL-35515_m24_yui371

      Description

      YUI 3.7.1 was just released...

        Gliffy Diagrams

          Issue Links

            Activity

            skodak Petr Skoda added a comment -

            I suppose this should be integrated asap, because this is what we should use in Moodle 2.4.

            If there are any regressions upstream we can use monkeypatching, my +1 to keep this version throughout 2.4.x if possible.

            skodak Petr Skoda added a comment -

            added YUI 3.7.1 instead - contains some fixes for utf8

            poltawski Dan Poltawski added a comment -

            The main moodle.git repository has just been updated with latest weekly modifications. You may wish to rebase your PULL branches to simplify history and avoid any possible merge conflicts. This would also make integrator's life easier next week.

            TIA and ciao

            stronk7 Eloy Lafuente (stronk7) added a comment -

            Integrated, thanks!

            markn Mark Nelson added a comment - - edited

            Alright, so since this test doesn't really have any set path you should take to test it I will list the steps I took.

            1. Visited a course page in editing mode.
            2. Clicked to add a file resource.
            3. Drag and dropped a file.
            4. Clicked to add a file, clicked 'Upload a file' and browsed to a file.
            5. Added a SCORM package.
            6. Enrolled a few users.
            7. Visited the gradebook and switched between users and reports.
            8. Created a group, which then lead me to find a PHP error which I created ticket for.
            9. Assigned users to the group and performed a search for a user using the JS search functionality.
            10. Created multiple cohorts.
            11. Assigned users to the cohorts.
            12. Visited a course's enrolment page and clicked to enrol a cohort, used the search functionality to find the cohort I wanted.
            13. Went back to the course page and changed the positioning of an activity and received the following error on line 52 of yuilib/3.7.1/build/dd-ddm/dd-ddm.js

            TypeError: this._pg is null
            this._pg.setStyle('display', 'none');

            However, after trying to replicate this error again I could not.

            14. Moved course sestions around.

            I also received the following warning multiple times during testing when using the file picker on line 195 of im/lib/yuilib/3.7.1/build/dom-base/dom-base.js

            Use of attributes' specified attribute is deprecated. It always returns true.
            return (attrs.value && attrs.value.specified) ? node.value : node.text;

            I am not passing this for now, however, none of these JS issues prevented the operation from working. I am just erring on the side of caution to ensure someone reads these comments before being put into core. The only error I actually saw couldn't be replicated, and even when it did occur it didn't prevent the functionality from working.

            skodak Petr Skoda added a comment -

            Thanks! Could you please create new issues for 13. and 14. and assign it to maintainer of dnd and filepicker?

            What browser exactly did you use for testing? Did you test these problems did not happen before the new YUI?

            markn Mark Nelson added a comment -

            I was using Firefox version 15.0.

            1. I created a tracker issue for the error, but unfortunately since I can't replicate not sure if this can be resolved unless someone else can.
            2. After using Moodle version 2.2 and 2.3 as well I received the same warning, please see http://tracker.moodle.org/browse/MDL-35649

            stronk7 Eloy Lafuente (stronk7) added a comment -

            So, then found problems can be consider not to be introduced by this?

            Sending back to testing status so tester can decide about it.

            TIA and ciao

            markn Mark Nelson added a comment -

            I am passing this now. The error can not be reproduced and the warning affects various Moodle versions, so this library introduces no new issues.

            poltawski Dan Poltawski added a comment -

            Congratulations, you've done it!

            Nf n erjneq sbe fhpprfshy vagrtengvba vagb guvf jrrxf eryrnfr, V pna abj qvfpybfr gb lbh gur rkvfgnapr bs shapgvba fge_ebg13(), gb tb va lbhe gbbyxvg nybat jvgu uggc://cuc.arg/znahny/ra/shapgvba.tmtrgff.cuc

            Cyrnfr qb abg nyybj guvf vasbezngvba gb cnff shegure.


              People

              • Votes:
                0 Vote for this issue
                Watchers:
                1 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:
                  Fix Release Date:
                  3/Dec/12