Moodle
  1. Moodle
  2. MDL-35581 META: tasks related to RTL theme fixes before 2.4 freeze (Week 39)
  3. MDL-35563

Description field in all system setting pages should have "right margin" set properly, in RTL mode

    Details

    • Type: Sub-task Sub-task
    • Status: Closed
    • Priority: Minor Minor
    • Resolution: Fixed
    • Affects Version/s: 2.3
    • Fix Version/s: 2.4
    • Component/s: Themes
    • Labels:
    • Testing Instructions:
      1. Install an Hebrew (RTL) language pack, and switch to Hebrew
      2. Login as Admin.
      3. Navigate to one or several "Plugin settings" pages under the Admin Settings Menu.
      4. See the issues listed above (Description section & screen capture images)
      5. Apply the patch
      6. Reload the page(s) and verify the issue is solved. (Switch "Theme Designer mode" = On, if necessary)
      Show
      Install an Hebrew (RTL) language pack, and switch to Hebrew Login as Admin. Navigate to one or several "Plugin settings" pages under the Admin Settings Menu. See the issues listed above (Description section & screen capture images) Apply the patch Reload the page(s) and verify the issue is solved. (Switch "Theme Designer mode" = On, if necessary)
    • Affected Branches:
      MOODLE_23_STABLE
    • Fixed Branches:
      MOODLE_24_STABLE
    • Pull from Repository:
    • Pull Master Branch:
      WIP-MDL-35563-master

      Description

      Description field in all system setting pages should have "right margin" set properly, in RTL mode

      Minor UI and usability fix
      Change:

       #adminsettings .form-item .form-description {margin: 0.5em 0 0 14.25em;}

      To:

       #adminsettings .form-item .form-description {margin: 0.5em 14.25em;}

        Gliffy Diagrams

          Activity

          Nadav Kavalerchik added a comment -

          While testing this patch, I found out that their are some more (minor but important) CSS fixes that are needed for this issue to be solved, They are all added as commits to the branch "WIP-MDL-35563" which now seems to solve this issue. (for all the various system setting pages)

          Mary Evans added a comment -

          I have set this for integration so can you add Test Instructions just something simple.

          Thanks M

          Eloy Lafuente (stronk7) added a comment -

          Sorry reopening, this is conflicting right now.

          Nadav Kavalerchik added a comment -

          I have fixed the conflics (after rebasing with recent master)

          CiBoT added a comment -

          Moving this reopened issue out from current integration. Please, re-submit it for integration once ready.

          Nadav Kavalerchik added a comment -

          @Mary

          While rebasing this fix... I came out with a better fix for this issue. and changed the CSS rules a little bit different.
          I think, now, it is better. please review it

          Nadav Kavalerchik added a comment -

          Rebased over latest master (6-10-2012). Ready for integration

          Dan Poltawski added a comment -

          Integrated to master.

          Thanks!

          Rossiani Wijaya added a comment -

          Failing this test due to incorrect alignment for config name.
          patch link: https://github.com/nadavkav/moodle/compare/master...WIP-MDL-35563-master#L0R166

          I'm also attaching screenshot for this.

          Dan Poltawski added a comment -

          Rosie: just confirming you've purged caches?

          Rossiani Wijaya added a comment -

          Yes, I purge my caches.

          Nadav Kavalerchik added a comment -

          I was looking at your screen capture and ...
          the "config name" is correctly aligned to the left, since it is an English word
          the "config name title" is correctly aligned to the right, since it is translated into Hebrew
          All seems perfect, looking at what you consider an error in the UI on the screen capture you took

          Please pass this test, since this is how it should look like.

          Dan Poltawski added a comment -

          Rosie & I discussed and are OK to pass this

          Aparup Banerjee added a comment -

          Your issue has dug up some gold.
          It works great i've been told.
          Go forth, be brave, be bold.

          yay! "All your thoughts are belong to everyone."

          Thanks and ciao!


            People

            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: