Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-35581 META: tasks related to RTL theme fixes before 2.4 freeze (Week 39)
  3. MDL-35566

Always, left align "Version" and "Folder" fields,in RTL and LTR modes. (Check available updates page)

    Details

    • Type: Sub-task
    • Status: Closed
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: 2.3.2
    • Fix Version/s: 2.4
    • Component/s: Themes
    • Labels:
    • Testing Instructions:
      1. Install an Hebrew (RTL) language pack, and switch to Hebrew
      2. Install some 3rd party plugins (just copy it into it's proper folder. you do not need to install it actually!)
      3. Login as Admin. And Reload Moodle's frontpage... you should be redirected automatically to "Check and Update plugins" page. (If not, navigate to it from Admin's main menu)
      4. See the issues listed above (Description section)
      5. Apply the patch
      6. Reload the page and verify the issue is solved - All above fields are left justified.
      7. Delete the 3rd party plugin folder you used to test this issue!!!
      Show
      Install an Hebrew (RTL) language pack, and switch to Hebrew Install some 3rd party plugins (just copy it into it's proper folder. you do not need to install it actually!) Login as Admin. And Reload Moodle's frontpage... you should be redirected automatically to "Check and Update plugins" page. (If not, navigate to it from Admin's main menu) See the issues listed above (Description section) Apply the patch Reload the page and verify the issue is solved - All above fields are left justified. Delete the 3rd party plugin folder you used to test this issue!!!
    • Affected Branches:
      MOODLE_23_STABLE
    • Fixed Branches:
      MOODLE_24_STABLE
    • Pull from Repository:
    • Pull Master Branch:
      WIP-MDL-35566

      Description

      When "Checking for available updates" page (admin/index.php) in RTL mode

      Always, left align "Version" and "Folder" fields,
      in LTR and RTL modes

        Gliffy Diagrams

          Activity

          nadavkav Nadav Kavalerchik added a comment -

          I have added a second commit to this issue's fix branch (WIP-MDL-35566), since it fixes a minor issue in the "update report" maintenance page that comes directly after submitting this issue's page ("check updates" page) which was very hard to screen capture. It seems related.

          lazydaisy Mary Evans added a comment -

          Please add test instructions. Thanks M

          stronk7 Eloy Lafuente (stronk7) added a comment - - edited

          Uhm, Nadav...

          I don't get why you need to specify:

          .pagelayout-maintenance {text-align: center;}
          .dir-rtl.pagelayout-maintenance {text-align: center;}

          Or I'm wrong or the 1st selector covers both rtl and ltr, isn't it?

          Reopening...ciao

          Edited: Also, isn't that selector way too generic? It applies to the whole pagelayot, isn't it? I can imagine problems if later we want to introduce other contents.

          nadavkav Nadav Kavalerchik added a comment -

          Eloy, you are right. the second line ".dir-rtl..." was a test, that slipped in, oups.
          It is redundant and actually... I do not think there is a "dir-rtl" class on that page, in the first place.
          It was suppose to solve another related issue in which: "After clicking UPGRADE on the above page, And while viewing the report page for upgrading the DB tables, all text on the page was aligned to the right. where it better stay centered like in LTR mode" ( I will try to add a screen capture of this too )

          Now, since I can only see this issue when I am installing or upgrading components
          I am leaving it open until I get a chance at fixing it again.

          Thanks

          nadavkav Nadav Kavalerchik added a comment -

          Ok. that was quick. ( I had to upgrade some plugin on some system... )
          And captured a new screen shot of the second issue.
          I LOVE some CSS developer help on this one, since i can not figure it out. (why the page is right aligned)

          cibot CiBoT added a comment -

          Moving this reopened issue out from current integration. Please, re-submit it for integration once ready.

          nadavkav Nadav Kavalerchik added a comment -

          Eloy,

          I have removed the second (the minor additional issue) commit from the branch.
          It has only the original intended fix for this issue.
          I have rebased it over latest moodle.org.master (29-9-2012)
          Please see if you can integrate it

          nadavkav Nadav Kavalerchik added a comment -

          Rebased over latest master (6-10-2012). Ready to integrate

          nebgor Aparup Banerjee added a comment -

          The main moodle.git repository has just been updated with latest weekly modifications. You may wish to rebase your PULL branches to simplify history and avoid any possible merge conflicts. This would also make integrator's life easier next week.

          TIA and ciao

          nadavkav Nadav Kavalerchik added a comment -

          Rebased over latest master (19-10-2012). Ready to integrate

          poltawski Dan Poltawski added a comment -

          The main moodle.git repository has just been updated with latest weekly modifications. You may wish to rebase your PULL branches to simplify history and avoid any possible merge conflicts. This would also make integrator's life easier next week.

          TIA and ciao

          nadavkav Nadav Kavalerchik added a comment -

          Rebased over latest master (1-11-2012). Ready to integrate

          nebgor Aparup Banerjee added a comment -

          Hi Nadav,
          this look fine but some minor suggestion:

          • i would group the #plugins-check css together with the ones above for better readability
          nadavkav Nadav Kavalerchik added a comment -

          Aparup, You are right. Do you want me to change the code and update the branch on github.com before you integrate it or do you want to do it yourself?

          nadavkav Nadav Kavalerchik added a comment -

          OK. fixed it

          nebgor Aparup Banerjee added a comment -

          Thanks Nadav

          integrated into master only.

          nebgor Aparup Banerjee added a comment -

          this tested fine

          stronk7 Eloy Lafuente (stronk7) added a comment -

          Amazed. Inspired. Grateful. That’s how your generosity makes me feel.

          (not really)

          Closing, thanks!


            People

            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:
                Fix Release Date:
                3/Dec/12