Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-35581

META: tasks related to RTL theme fixes before 2.4 freeze (Week 39)

    Details

    • Type: Bug
    • Status: Open
    • Priority: Minor
    • Resolution: Unresolved
    • Affects Version/s: 2.3
    • Fix Version/s: STABLE backlog
    • Component/s: Themes
    • Labels:
    • Affected Branches:
      MOODLE_23_STABLE

      Description

      List of sub tasks (issues) to be code reviewed, integrated and tested before code freeze (in three weeks from now)
      Mostly related to theme/base

        Gliffy Diagrams

        1.
        Right align registration text on login page, when in RTL mode Sub-task Closed Nadav Kavalerchik
         
        2.
        Left justify LTR Form input fields (email, idnumber, url, phone...), when in RTL mode Sub-task Closed Nadav Kavalerchik
         
        3.
        Right padding is missing on Date field/element, when in RTL mode (minor fix) Sub-task Closed Nadav Kavalerchik
         
        4.
        RTL fixes to theme/magazine Sub-task Closed Mary Evans
         
        5.
        Always, left align "Version" and "Folder" fields,in RTL and LTR modes. (Check available updates page) Sub-task Closed Nadav Kavalerchik
         
        6.
        Several RTL UI fixes for Course Overview block, in RTL mode Sub-task Closed Nadav Kavalerchik
         
        7.
        Description field in all system setting pages should have "right margin" set properly, in RTL mode Sub-task Closed Nadav Kavalerchik
         
        8.
        Left justify CLOSE button on modal dialog boxes, when in RTL mode Sub-task Closed Nadav Kavalerchik
         
        9.
        Two left pointing arrows appear after clicking "left indent activity/resource" arrow, when in RTL mode Sub-task Closed Nadav Kavalerchik
         
        10.
        Right align course & category names (theme/mymobile) when in RTL mode Sub-task Closed Mary Evans
         
        11.
        Invert "search option" listbox "open" arrow, when in RTL mode (page: manual user course registration ) Sub-task Closed Nadav Kavalerchik
         
        12.
        Left align INPUT boxes and TEXT boxes during Install process, when in RTL mode Sub-task Closed Nadav Kavalerchik
         
        13. Right align all TABs in all TinyMCE dialogs, when in RTL mode Sub-task Reopened Nadav Kavalerchik
         
        14.
        Grading popup menu, in Assignment grading page, should open up to the left, when in RTL mode Sub-task Closed Nadav Kavalerchik
         
        15.
        Invert all action arrows in Question Bank categories management, when in RTL mode Sub-task Closed Nadav Kavalerchik
         
        16.
        Help popups misaligned for right-to-left languages Sub-task Closed Simon Coggins
         
        17.
        Unable to set a new grade or update old grade when using the new Assignment type (Assign) while in Hebrew UI Sub-task Closed Damyon Wiese
         
        18.
        RTL fixes to theme/canvas (and theme/magazine) Sub-task Closed Nadav Kavalerchik
         

          Activity

          stronk7 Eloy Lafuente (stronk7) added a comment -

          Hi Nadav... just one comment about your testing instructions... while they are nice... surely it would be better if you put there only the steps to be tested and the expected results. (and not the results before the patch). Testers cannot (generally) perform the steps before the patch, because it has been already applied, so that part is somehow, useless (or could be moved to the description of the issue, sort of "to reproduce" explanation.

          Note that you don't need to amend them this time, as far as I'm testing the before / after results while integrating the issues but, for the future, it's better to focus exclusively on testing steps and results AFTER the patch is applied.

          Ciao

          salvetore Michael de Raadt added a comment -

          Thanks for bringing these issues together.

          This issue can be closed as fixed when all its sub-tasks are resolved.

          nadavkav Nadav Kavalerchik added a comment -

          Eloy,
          Thank you for your comment. I got over excited with filling those Test Instructions. Since I was not sure who is doing the tests and what is their Moodle's state and technical knowledge.

          Since most of my patches are for RTL bugs... I am using a "Test Instruction" template, I made for my self, in which I make little changes and adopt it for each issue. I will take off the "before the patch" part.

          BTW, If you have a good example of an issue with some clear "Test Instruction", I would LOVE to see...


            People

            • Votes:
              1 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated: