Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-35619

Userpics on page enrol other users are broken.

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: 2.3.2
    • Fix Version/s: 2.2.6, 2.3.3
    • Component/s: Enrolments
    • Labels:
    • Testing Instructions:
      Hide

      1/ create some users
      2/ add user avatars
      3/ go to empty course
      4/ go to "Other users page"
      5/ add roles for some users with avatars
      6/ verify the avatars display fine

      Show
      1/ create some users 2/ add user avatars 3/ go to empty course 4/ go to "Other users page" 5/ add roles for some users with avatars 6/ verify the avatars display fine
    • Affected Branches:
      MOODLE_23_STABLE
    • Fixed Branches:
      MOODLE_22_STABLE, MOODLE_23_STABLE
    • Pull from Repository:
    • Pull Master Branch:
      w40_MDL-35619_m24_otheravatars

      Description

      When I open the page to enrol other users in a course (/enrol/otherusers.php) all user-images were broken.

        Gliffy Diagrams

          Attachments

            Activity

            Hide
            skodak Petr Skoda added a comment -

            I can not reproduce this unless I enable Gravatar icons - see MDL-35669 for recent regression there.

            Thanks for the report, please comment here if you did not enable Gravatar and find steps how to reproduce this on a different server.

            Show
            skodak Petr Skoda added a comment - I can not reproduce this unless I enable Gravatar icons - see MDL-35669 for recent regression there. Thanks for the report, please comment here if you did not enable Gravatar and find steps how to reproduce this on a different server.
            Hide
            schorsch101 Dennis Meyer added a comment -

            Thank you for your reply.

            I don't use Gravatar.

            My steps:
            -create a course
            -enrol myself as teacher
            -course-administration
            -enrol
            -enrol other users

            On that page all users with default UserPic are ok - every user with a personalized pic is broken (wrong UserID in the <img-TAG-path :-/ - the names in the <IMG-Tag are correct.

            I can reproduce it on two different moodles (2.3.2+)

            Show
            schorsch101 Dennis Meyer added a comment - Thank you for your reply. I don't use Gravatar. My steps: -create a course -enrol myself as teacher -course-administration -enrol -enrol other users On that page all users with default UserPic are ok - every user with a personalized pic is broken (wrong UserID in the <img-TAG-path :-/ - the names in the <IMG-Tag are correct. I can reproduce it on two different moodles (2.3.2+)
            Hide
            skodak Petr Skoda added a comment -

            Oh, I managed to reproduce it now, thanks a lot!

            Show
            skodak Petr Skoda added a comment - Oh, I managed to reproduce it now, thanks a lot!
            Hide
            poltawski Dan Poltawski added a comment -

            I've been tripped up by this exact same thing myself quite recently. I wonder if we need to do something to help developers catch this problem.

            Show
            poltawski Dan Poltawski added a comment - I've been tripped up by this exact same thing myself quite recently. I wonder if we need to do something to help developers catch this problem.
            Hide
            poltawski Dan Poltawski added a comment -

            Thanks Petr, i've integrated this now.

            Show
            poltawski Dan Poltawski added a comment - Thanks Petr, i've integrated this now.
            Hide
            timb Tim Barker added a comment -

            Avatars appear fine. Great work

            Show
            timb Tim Barker added a comment - Avatars appear fine. Great work
            Hide
            stronk7 Eloy Lafuente (stronk7) added a comment -

            Closing as fixed, many thanks for your awesome collaboration.

            Show
            stronk7 Eloy Lafuente (stronk7) added a comment - Closing as fixed, many thanks for your awesome collaboration.

              People

              • Votes:
                0 Vote for this issue
                Watchers:
                1 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:
                  Fix Release Date:
                  12/Nov/12