Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-35636

login/token.php: confusing "create user token" log appearing before "token user request"

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: 2.2.5, 2.3.2
    • Fix Version/s: 2.4
    • Component/s: Web Services
    • Labels:
    • Testing Instructions:
      Hide

      Require web service client creation experience.

      1) Enable mobile service in the Moodle admin
      2) http://docs.moodle.org/dev/Creating_a_web_service_client#How_to_get_a_user_token
      Call login/token.php following the documentation. Checks Moodle logs (in the Moodle admin), you should see the new info "sending requested user token".

      Show
      Require web service client creation experience. 1) Enable mobile service in the Moodle admin 2) http://docs.moodle.org/dev/Creating_a_web_service_client#How_to_get_a_user_token Call login/token.php following the documentation. Checks Moodle logs (in the Moodle admin), you should see the new info "sending requested user token".
    • Affected Branches:
      MOODLE_22_STABLE, MOODLE_23_STABLE
    • Fixed Branches:
      MOODLE_24_STABLE
    • Pull Master Branch:

      Attachments

        Issue Links

          Activity

            People

            Assignee:
            jerome Jérôme Mouneyrac
            Reporter:
            jerome Jérôme Mouneyrac
            Peer reviewer:
            Rajesh Taneja
            Integrator:
            Dan Poltawski
            Tester:
            David Monllaó
            Participants:
            Component watchers:
            Juan Leyva, Amaia Anabitarte, Carlos Escobedo, Ferran Recio, Ilya Tregubov, Sara Arjona (@sarjona)
            Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved:
              Fix Release Date:
              3/Dec/12