Moodle
  1. Moodle
  2. MDL-35641

Backport Flowplayer update to resolve erratic player behaviour

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Critical Critical
    • Resolution: Fixed
    • Affects Version/s: 2.2.5, 2.3
    • Fix Version/s: 2.3.5
    • Component/s: Filters
    • Labels:
    • Testing Instructions:

      Borrowed from MDL-35185:

      With MOODLE_23_STABLE:

      1/ get some mp3s and flash videos
      2/ create some activities that use these media files
      3/ enable media embedding everywhere
      4/ test using
      4a/ browser with flash
      4b/ browser without flash
      5c/ mobile browser

      Make sure the video/audio embedding works as before.

      Note, take a look to the testing phase @ MDL-35185. Any problem should be reported in different issue to be fixed against all supported versions.

      Show
      Borrowed from MDL-35185 : With MOODLE_23_STABLE: 1/ get some mp3s and flash videos 2/ create some activities that use these media files 3/ enable media embedding everywhere 4/ test using 4a/ browser with flash 4b/ browser without flash 5c/ mobile browser Make sure the video/audio embedding works as before. Note, take a look to the testing phase @ MDL-35185 . Any problem should be reported in different issue to be fixed against all supported versions.
    • Affected Branches:
      MOODLE_22_STABLE, MOODLE_23_STABLE
    • Fixed Branches:
      MOODLE_23_STABLE
    • Pull from Repository:

      Description

      As originally reported on forums (http://moodle.org/mod/forum/discuss.php?d=204461), several of us have found erratic behavior with the embedded mp3 flash player in Moodle 2.3:

      • Chrome: works as expected
      • Firefox 14 and IE 8 & 9: Clicking the Pause button does not pause the player, instead, it moves erratically, and plays more than one instance of the audio file! In addition, the player will sometimes freeze after two plays (but not consistently).

        Gliffy Diagrams

          Activity

          Michael de Raadt added a comment -

          Hi, Don.

          Thanks for reporting that.

          I assume you are talking about the Flow player and you have the Miltimedia filter turned on.

          Or do you have PoodLL or some other player installed?

          Antonio Vilela added a comment - - edited

          Hi. One of our customers reported the same problem using mp3 and flowplayer. In fact it happens to me on IE9 with shokwave flash plugin 11.4.402.278 (recently updated). When I click pause, nothing happens. When I click pause again, a new playing starts simultaneously to the previous one. This can be really annoying and is blocker to language teaching. In my firefox it shows only a black strip with nothing inside. In chrome the problem didn't happen until I refreshed the page and started showing the same behaviour.

          Michael de Raadt added a comment -

          Hi, all.

          I was able to reproduce this in 2.3 stable, but it has been fixed by a recent update of Flowplayer that has been made in MDL-35185.

          I'm going to change this issue to a backport issue.

          Michael de Raadt added a comment -

          Normally we would not backport third-party plugin updates, but as the previous version of Flowplayer has been affected by recent Flash add-on changes, we should consider this.

          Don Hinkelman added a comment -

          Hi Michael,
          Thanks for working on this so quickly and raising its level to critical--for us language teachers, it is indeed almost a blocker for our students.
          Sorry, I do not know what Flowplayer is. The problem I am referring to is the small, thin mp3 player that appears inside the quiz question when the multi-media filter is turned on. Maybe that is called Flowplayer? I have also heard that PoodLL conflicts might occur, but we do not have PoodLL installed in this, our production server (also I heard Justin is working on a fix right now). I believe there are no other players installed. So by "backporting" the issue, does that mean there will be a new update shortly?

          Justin Hunt added a comment -

          We also had this problem when using the Flowplayer ( 3.2.9 )with PoodLL. It occurred when the flowplayer javascript code ( flowplayer-3.2.9.min.js )was loaded multiple times on the same page, instead of just once.

          Once we avoided that happening, everything went fine.

          Don Hinkelman added a comment -

          I am still not sure what Flowplayer is, but it is critical that multiple audio tracks play on the same page, and multiple tracks be playable within the same question. For example, we often use a multiple choice question where a audio track is played, and the four possible answers are also audio tracks (not written text). This is very useful in language teaching. Last semester, using Moodle 2.2, this kind of question was possible, and we encountered no problems.

          Peter Ruthven-Stuart added a comment -

          Don, Flowplayer is the Open Source flash video and audio player that Moodle uses to embed and play multimedia.

          Here's the Flowplayer web site:
          http://flowplayer.org/

          i.e. the "embedded mp3 flash player" that you refer to in your original post is generated by Flowplayer, unless you are using a third party filter such as PoodLL to display multimedia (video and audio).

          Heiko Schach added a comment -

          Can confirm the same erratic behaviour in Moodle 2.2.5 (Flowplayer version 3.2.7).
          Tested many environments and the only setup I've seen this working as it should lately is Linux with Firefox 15.01 and Adobe Flash Player 11.2.202.238, probably because of the older Flash version in Linux.

          The latest version of Flowplayer Flash v3.2 seems to be 3.2.15
          http://flash.flowplayer.org/documentation/version-history.html

          Fernando Oliveira added a comment -

          As far as I can tell, the media player won't show for any MP3 links within the new assignment module. Seems fine in other places. At least that's our experience. We're running Moodle 2.3.2+ (Build: 20120927).

          olivier delhaye added a comment -

          The problem is quite urgent for us language teachers. Really strange: for example, two computers with the same config (win7, ff 15.0.1) -> the player appears only on one of them ... [Moodle 2.3.2+ (Build: 20120927)]

          Petr Skoda added a comment -

          Here is a backport for Moodle 2.3.x https://github.com/skodak/moodle/compare/MOODLE_23_STABLE...wip_MDL-35641_m23_flowbackport
          Please note I did not test it much, I do not know if it fixes this particular problem or not.

          Don Hinkelman added a comment -

          Thank you, Petr, and others. At Sapporo Gakuin University, we have patched the 13 files (9 updates, 4 deletes) you have changed in github into our production server (which is using 2.3.2 Build 20120910). From what I understand this process updates the Flowplayer to version 3.2.14. In our brief testing, it appears the erratic problems have been solved. We experienced no multiple simultaneous plays of a recording and no freezing of the player. We could use multiple mp3 audio players on the same page. Our university client computers are using Flash ver. 11.4.402 and we will ask our teachers to continue to monitor the situation and I will report back here. Much appreciation for the quick work done!

          Rex Lorenzo added a comment -

          I would also like to chime in that this fixes the mp3 seeking/playback problems for us at UCLA on our test server. I am waiting for an official okay from our tester, but looks like a straight forward upgrade. Did notice that the playback UI looks a bit different. The buttons appear to have been made larger.

          John Brine added a comment -

          This problem is affecting hundreds of students in our classes.

          Don Hinkelman added a comment -

          Dear Michael and Petr,
          Although this issue is marked "unresolved" as of 15 October, the Petr's published fix has worked in our site and Rex's site. For others who wish to fix their site, can they just download the latest 2.2.x+ or 2.3.x+ release to remedy this issue?
          Thanks, Don

          Rex Lorenzo added a comment -

          I am still getting feedback from our students that they are still experiencing problems.

          I did more testing and I can pause and play, but I noticed that when I play an MP3 the progress bar is all the way to the right and I cannot seek/fast forward through the mp3 file. I am sure this has something to do with the fact that the file isn't being served from a streaming server, but have you always not been able to fast forward and skip around in an mp3 file?

          Also, also trying to skip to another part in the mp3 pauses the audio and I cannot get it to play again. So this is very annoying for long mp3 clips.

          Cleve added a comment -

          Dear Michael and experts, I share this problem as well. This is affecting around 80 students in our mindfulness course. The player does not pause, or fast-forward, and they do not see the total duration of the audio. This function beomces important when students have to take a braek from a 2 hour lecture. We would really appreciate any assistance on resolving this.
          Thank you,
          Cleve

          Michael de Raadt added a comment -

          Don: The problem does not appear in the latest weekly release. If you were going to upgrade to resolve this problem, you would need to get that version. The new Flow player will be in 2.4.

          It looks like we have conflicting results when Petr's patch is applied. Don says it works and Rex says it doesn't. How can that be?

          John Brine added a comment -

          After installing the latest weekly release, the problem persists. After playing an mp3 twice within any quiz, the position indicator freezes at the extreme right hand position on the progress bar as depicted in the above PNG posted by Rex Lorenzo.

          Don Hinkelman added a comment -

          I tested our site again, and I can confirm that all problems have been solved (other than complaints about the design of the player, which is another issue). The position indicator starts on the left, can be stopped and started, and does not freeze after two plays. The difference between my site and John's, is that on our site, we did 13 individual patches to install Petr's solution while John installed the latest weekly release. That is the only clue I know as to why John and Rex are continuing to have problems.

          John Brine added a comment -

          As we begin another week with this Flowplayer problem, I would like to reiterate that "After playing an mp3 twice within any quiz, the position indicator freezes at the extreme right hand position on the progress bar as depicted in the above PNG."

          Though others may have technical support, we depend on the STABLE release, and wonder when Petr's solution will be incorporated. Thank you.

          Michael de Raadt added a comment -

          Hi, John.

          This solution has not been integrated into weekly branches yet. You would need to apply the patch manually.

          Rex, can you perhaps do some further investigation?

          Rex Lorenzo added a comment -

          Michael, the problem still exists even with the updated flowplayer library. You can now pause/play, but you cannot "seek" in the mp3 file.

          Also, hitting play does not give you the progress or timestamp of where you are in the file. The progress bar is to the extreme right.

          Don, did you try skipping through the an mp3 track? It doesn't work on Chrome/Firefox. I am also guessing it doesn't work on more browsers.

          Tõnis Tartes added a comment -

          I can confirm there are some problems with seeking on the bar in the flowplayer with Petr's patch applied.
          Aslong you dont seek on the bar it works fine, anyway this is still better than it was with the behaviour without the patch applied.
          Using Moodle 2.3.3+

          Eric Katchan added a comment -

          Just applied the patch to our new moodle 2.3 and the start and stop button working but only once. I was unable to restart the player.

          current veersion Moodle 2.3.3+ (Build: 20121214)

          Dan Poltawski added a comment -

          +1 to backport this - it seems to be affecting a lot of people.

          Damyon Wiese added a comment -

          +1 for backport - this seems like more of an important bug fix than an improvement.

          Eloy Lafuente (stronk7) added a comment -

          To avoid forgetting, from Petr, some comments above:

          Here is a backport for Moodle 2.3.x https://github.com/skodak/moodle/compare/MOODLE_23_STABLE...wip_MDL-35641_m23_flowbackport
          Please note I did not test it much, I do not know if it fixes this particular problem or not.

          If anybody can feedback about that solution... it would be great.

          Ciao

          Eloy Lafuente (stronk7) added a comment -

          Extensive testing (mp3/flash... mobile...) will be needed here, indeed.

          Petr Skoda added a comment -

          If there is a problem with the patch above then most probably we have the same problem in 2.4 and master too - that would be a separate issue.

          Eloy Lafuente (stronk7) added a comment -

          Integrated (23 backport), thanks!

          To tester: Note this doesn't fix everything, but there are still some issues with flowplayer. Anything (wrong) found should lead to separate issues if they don't exist already in order to fix it for all supported branches. See MDL-35185 for the results of testing there.

          Dan Poltawski added a comment -

          The testing instructions are useless, from a quick read of the flowplayer website:

          1. There is no flash fallback for playing mp3's (so that shouldn't be working)
          2. The fallback whcih should be tested is mpeg4/ogg files
          Mark Nelson added a comment -

          The testing instructions were pretty bad tbh. I assume 'works as before' means as it behaved in stable, and not that the player works when flash is either disabled or enabled.

          My results for both integration/stable.

          When flash was enabled: Could play/pause the mp3 and flash video in the browser.
          When flash was disabled: The mp3 and flash file were not embedded, with only links shown where I could download the file.
          On iOS 6.1.2: Clicking on the mp3 provided a 'Cannot play audio file' message and clicking on the flash file provided a link to download it.

          Eloy Lafuente (stronk7) added a comment -

          Because

          A
          MARVELOUS
          A       U
          Z  YOU  P
          I  ARE  E
          N  PPL  R
          G       B
            TNKS! 
          

          Closing, ciao

          Doug Moody added a comment -

          I use version 2.4.1. This issue is NOT resolved. If I use Firefox, it works. But Chrome and IE do NOT work. If I disable Flash in IE, the players will not work.

          I have tested it with the standard Flowplayer MP3 player, as well as the Poodll MP3 player. Same results with either player.


            People

            • Votes:
              23 Vote for this issue
              Watchers:
              28 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: