Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-35665

Error displayed when setting an instance of mod_assign to be extra credit (backport of MDL-35389)

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: 2.3.2
    • Fix Version/s: 2.3.3
    • Component/s: Assignment, Gradebook
    • Labels:
      None
    • Testing Instructions:
      1. Create a assignment with mod_assign (new assignment module)
      2. Go to gradebook
      3. Click the pencil edit icon for the grade item. Not the one for a student grade. The one for the grade item itself.
      4. Tick the "extra credit" checkbox. You may need to display advanced.
      5. Verify you do not receive this error: Coding error detected, it must be fixed by a programmer: The property "context" is not set.
      Show
      Create a assignment with mod_assign (new assignment module) Go to gradebook Click the pencil edit icon for the grade item. Not the one for a student grade. The one for the grade item itself. Tick the "extra credit" checkbox. You may need to display advanced. Verify you do not receive this error: Coding error detected, it must be fixed by a programmer: The property "context" is not set.
    • Affected Branches:
      MOODLE_23_STABLE
    • Fixed Branches:
      MOODLE_23_STABLE

      Description

      Create an instance of mod_assign (new assignment module). Go into the gradebook and click the pencil edit icon for the grade item. Not the one for a student grade. The one for the grade item itself.

      Tick the "extra credit" checkbox. You may need to display advanced. The following error is displayed.

      Coding error detected, it must be fixed by a programmer: The property "context" is not set.
       
      More information about this error
      Debug info:
      Error code: codingerror
      Stack trace:
       
          line 668 of /grade/grading/lib.php: coding_exception thrown
          line 331 of /grade/grading/lib.php: call to grading_manager->ensure_isset()
          line 530 of /grade/grading/lib.php: call to grading_manager->get_active_method()
          line 370 of /mod/assign/feedback/offline/locallib.php: call to grading_manager->get_active_controller()
          line 4329 of /mod/assign/locallib.php: call to assign_feedback_offline->is_enabled()
          line 787 of /mod/assign/lib.php: call to assign->get_user_grades_for_gradebook()
          line 804 of /mod/assign/lib.php: call to assign_get_user_grades()
          line 1190 of /lib/gradelib.php: call to assign_update_grades()
          line 1448 of /lib/grade/grade_item.php: call to grade_update_mod_grades()
          line 535 of /lib/grade/grade_item.php: call to grade_item->refresh_grades()
          line 172 of /grade/edit/tree/item.php: call to grade_item->set_locked()

        Gliffy Diagrams

          Attachments

            Issue Links

              Activity

              damyon Damyon Wiese added a comment -

              This is the same issue as MDL-35389 which was fixed for 2.4 but not backported to 2.3 (my fault - should have checked).

              The change is the same and is definitely the cause of this issue.

              andyjdavis Andrew Davis added a comment -

              If thats the case this issue should be closed as duplicate rather than put up for integration. I don't seem to have the ability to close it now. I'm guessing we'll have to wait for the integrators to do that now.

              damyon Damyon Wiese added a comment -

              Should I re-open MDL-35389 then (it's already fixed for 2.4)?

              poltawski Dan Poltawski added a comment -

              We can carry on in this issue rather than reopen the other one.

              poltawski Dan Poltawski added a comment -

              Integrated to 2.3 only.

              rwijaya Rossiani Wijaya added a comment -

              Testing this in 2.3 only.

              The fixed works great.

              Test passed.

              stronk7 Eloy Lafuente (stronk7) added a comment -

              Closing as fixed, many thanks for your awesome collaboration.


                People

                • Votes:
                  1 Vote for this issue
                  Watchers:
                  2 Start watching this issue

                  Dates

                  • Created:
                    Updated:
                    Resolved:
                    Fix Release Date:
                    12/Nov/12