Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-35715

Dragging an activity out of a section removes the ability to drag back into that section if it's now empty

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Critical
    • Resolution: Fixed
    • Affects Version/s: 2.3.2, 2.4
    • Fix Version/s: 2.3.3
    • Component/s: JavaScript
    • Labels:
    • Testing Instructions:
      • Create a course
      • Turn editing on
      • Drag the 'News forum' out of the top section into another section (so that the section where it used to be is empty)
      • It should be possible to drag it back to the section where it used to be
      Show
      Create a course Turn editing on Drag the 'News forum' out of the top section into another section (so that the section where it used to be is empty) It should be possible to drag it back to the section where it used to be
    • Affected Branches:
      MOODLE_23_STABLE, MOODLE_24_STABLE
    • Fixed Branches:
      MOODLE_23_STABLE
    • Pull from Repository:
    • Pull Master Branch:
      MDL-35715-master

      Description

      • Create a course
      • Turn editing on
      • Drag the 'News forum' out of the top section into another section
      • Try to drag it back (you can't)
      • Refresh the page
      • Try to drag the 'News forum' back into the top section (it works now)
      • Try to drag it back to the section it was just in (you can't)

        Gliffy Diagrams

          Attachments

            Issue Links

              Activity

              dobedobedoh Andrew Nicols added a comment -

              I think Ruslan is probably the best person to deal with this issue

              kabalin Ruslan Kabalin added a comment -

              Can't replicate neither on master nor in MOODLE_23_STABLE. Tested with Chrome and Firefox...

              dobedobedoh Andrew Nicols added a comment -

              I can replicate on latest master.

              kabalin Ruslan Kabalin added a comment -

              Sorry, have not updated the master. Looking into the issue.

              kabalin Ruslan Kabalin added a comment -

              Regression caused by d2ce925279 (MDL-34328)

              kabalin Ruslan Kabalin added a comment -

              It appeared that only currently empty sections were marked as drop targets for resource elements, while we need to make all section drop targets as any of them could become empty as a result of relocating resources (like in the example used in description).

              kabalin Ruslan Kabalin added a comment -

              Added testing instruction.

              kabalin Ruslan Kabalin added a comment - - edited

              Added MOODLE_23_STABLE branch

              dobedobedoh Andrew Nicols added a comment -

              Looks good to me.
              Free free to submit to integration. This will need a MOODLE_23_STABLE branch too.

              dobedobedoh Andrew Nicols added a comment -

              p.s. you may want to expand the testing instructions to state that the activity needs to be moved out of a section such that the section is then empty.

              kabalin Ruslan Kabalin added a comment -

              Ready for integration

              stronk7 Eloy Lafuente (stronk7) added a comment -

              Integrated (23 & master), thanks!

              stronk7 Eloy Lafuente (stronk7) added a comment -

              Passed, now it works as expected (can send activity back to original section).

              stronk7 Eloy Lafuente (stronk7) added a comment -

              From somewhere within the clouds...

              Congrats, this has been sent upstream and is now part of Moodle (your favorite LMS platform). Many thanks for your awesome collaboration!

              Ciao


                People

                • Votes:
                  0 Vote for this issue
                  Watchers:
                  1 Start watching this issue

                  Dates

                  • Created:
                    Updated:
                    Resolved:
                    Fix Release Date:
                    12/Nov/12