Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-35760

Filemanager arrow displays to the left in Opera, Safari and IE10

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Blocker
    • Resolution: Fixed
    • Affects Version/s: 2.3
    • Fix Version/s: 2.3.4
    • Component/s: Filepicker
    • Labels:

      Description

      When uploading a file using the Filemanager in the latest version of Opera (12.02) the drag and drop arrow is rendered to the left of the Filemanager box.

        Gliffy Diagrams

        1. ie8-noarrow.png
          68 kB
        2. Safari-noarrow.png
          36 kB
        3. Selection_001.png
          18 kB

          Issue Links

            Activity

            salvetore Michael de Raadt added a comment -

            I tried to replicate this, but I got no arrow at all in Opera, just the dashed box.

            salvetore Michael de Raadt added a comment -

            This seems to be a problem in both Opera and Safari.

            I'm still not seeing any arrow in either browser under Windows.

            This was reported by Tim previously, but the issue was closed. Tim said he was able to resolve the problem by purging caches, but that did not make the arrow visible for me. It might be worth testing under MacOS to see if this resolves the alignment problem there.

            lazydaisy Mary Evans added a comment -

            @Michael

            I can fix this BUG but will need someone to Peer review the changes I will nee to make. Can I rely on you Michael?

            I don't like the way span is used to set the image, there are better alternatives, so I'd like the opportunity to try something else, if that's OK by everyone?

            lazydaisy Mary Evans added a comment -

            I got the arrow to show up correctly in Opera & IE9 I guess it will be the same for IE10, I don't have Safari.

            I have a feeling it's the SPAN tag that's causing the problem. SPAN works OK for text but it's not working in IE9 as you cannot see any text either.

            I'd really like to change the way the text and image is coded in core but cannot find the source code. I did find some in ../lib/outputrenderers.php but altering that made no difference, so I am guessing the real HTML markup is elsewhere. I wish I knew where to look!

            mina Nicolas Martignoni added a comment -

            This is still present in Safari as of Moodle 2.4beta (Build: 20121109), version 2012111200.00.

            salvetore Michael de Raadt added a comment -

            I'm elevating this to a blocker, now that it is blocking a QA test.

            Thanks for the work you've done exploring this, Mary. Sorry I didn't respond sooner.

            salvetore Michael de Raadt added a comment -

            I am able to reproduce this in IE10.

            salvetore Michael de Raadt added a comment -

            I'm assigning this to Mark to look at, as it is now urgent.

            lazydaisy Mary Evans added a comment - - edited

            I've been looking at this and have come up with a possible fix.

            /** this seems to be blocking the text message/arrow for IE9/10 Opera/Safari **/
            .dndupload-message {display:none;}
             
            /** add blue arrow to fm-content-wrapper .fm-empty-container **/
            .fm-content-wrapper .fm-empty-container {background:url([[pix:theme|fp/dnd_arrow]]) center no-repeat;}
             
            /** remove span.dndupload-arrow  **/
            .dndupload-arrow {background:url([[pix:theme|fp/dnd_arrow]]) center no-repeat;width:60px;height:80px;position:absolute;margin-left: -28px;top: 5px;}

            markn Mark Nelson added a comment -

            Hi Mary, I would avoid commenting out ".dndupload-message

            {display:none;}

            " and would just delete it. Git stores the history of the file, so if it is needed we can always look at past revisions.

            lazydaisy Mary Evans added a comment -

            OK...will do. Thanks

            lazydaisy Mary Evans added a comment -

            Looks like I did something wrong and so have deleted this branch and I am still getting a messed up master branch. I have obviously done something wrong, but can't see what, other than it's telling me that my local branch is 2 commits ahead of origin/master!

            lazydaisy Mary Evans added a comment -

            Fixed it

            samhemelryk Sam Hemelryk added a comment -

            Hi Mary,

            I'm sending this back sorry.
            Unfortunately the change breaks things on browsers that don't support drag and drop.
            The reason for the following line is to hide both the drag and drop message, and the arrow on browsers that don't support drag and drop:

            .dndupload-message {display:none;}

            In removing that line and moving the background image to a node outside the dndupload-message box things break.

            IE7 and IE8 are browsers which don't support drag and drop if you are interested in testing.

            Cheers
            Sam

            cibot CiBoT added a comment -

            Moving this reopened issue out from current integration. Please, re-submit it for integration once ready.

            lazydaisy Mary Evans added a comment -

            @Mark
            I've signed it over to you. Best of luck with this.

            markn Mark Nelson added a comment - - edited

            Thanks Mary, your previous comments lead me in the right direction. I have tested this on Chrome, Firefox and Opera. Fred has tested on IE (even though dnd is not enabled, he turned off display:none to see where it would be rendered if it was, and it is indeed correct) and Dan on Safari. Looks good.

            fred Frédéric Massart added a comment -

            Looks good Mark. Pushing for integration. Thanks!

            samhemelryk Sam Hemelryk added a comment -

            Thanks Mark, this has been integrated now.

            rajeshtaneja Rajesh Taneja added a comment -

            Sorry Mark,

            Can't see any arrow in IE8 and Safari.

            Visible in FF, Opera and chrome.

            rajeshtaneja Rajesh Taneja added a comment -

            Sorry for the noise guys,

            It works fine. IE8, don't support dnd of files.
            Sam, Can you please re-open this for testing.

            rajeshtaneja Rajesh Taneja added a comment -

            Thanks Dan and Mark,

            Works Grt. Haven't checked in ie10.
            Also, in safari D-n-d is not supported.

            mina Nicolas Martignoni added a comment -

            Hi Rajesh,

            I just tested it now and observed that drag-and-drop WORKS in Safari as of today, Version 6.0.2 (8536.26.17), on Mac OS X.

            Thank you all for the great work

            stronk7 Eloy Lafuente (stronk7) added a comment -

            Y E S !

            Closing as fixed, many thanks!


              People

              • Votes:
                1 Vote for this issue
                Watchers:
                2 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:
                  Fix Release Date:
                  14/Jan/13