Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-35842

add an "alphabetical order" option to the random glossary entry block

    Details

    • Type: Improvement
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 2.3
    • Fix Version/s: 2.5
    • Component/s: Blocks, Glossary
    • Labels:

      Description

      See this discussion: http://moodle.org/mod/forum/discuss.php?d=213034
      I am attaching a very simple patch to add an "alphabetical order" display option to the random glossary entry block.
      Joseph

        Gliffy Diagrams

          Attachments

            Activity

            salvetore Michael de Raadt added a comment -

            Thanks for suggesting that and providing a patch.

            rezeau Joseph Rézeau added a comment -

            starting review

            rezeau Joseph Rézeau added a comment -

            Hi Jason,

            On my local install of moodle I checked from your Repository: git://github.com/phalacee/moodle.git the wip-MDL-35842-master branch to my moodle 2.3.
            However, this throws the error: Table "course_format_options" does not exist
            The problem is that we are currently testing the patch for moodle 2.3 but your wip-MDL-35842-master branch seems to have been made for the Moodle master (aka 2.4) branch.
            Can you confirm this?
            Should I rather check your patch to my local 2.4 moodle install rather than 2.3?
            Joseph

            phalacee Jason Fowler added a comment -

            Hi Joseph,

            My patch is only for 2.4, and this is an improvement, which means it should only be submitted for 2.4

            I have no idea what the course_format_options has to do with this patch in particular, but there has been a lot of work on course formats for 2.4 - maybe cherry-picking the patch back on to a 2.3 branch will avoid those issues.

            Hope this helps.

            rezeau Joseph Rézeau added a comment -

            Tested on a moodle 2.4 installation. Works as expected.

            rezeau Joseph Rézeau added a comment -

            works as expected (moodle 2.4)

            phalacee Jason Fowler added a comment -

            Thanks Joseph, pushing for integration now.

            samhemelryk Sam Hemelryk added a comment -

            Thanks Jason, this has been integrated now.

            abgreeve Adrian Greeve added a comment -

            Tested on the master integration branch.
            Works as described.
            Test passed.

            stronk7 Eloy Lafuente (stronk7) added a comment -

            And your fantastic code has met core, hope they become good friends for a long period.

            Closing, thanks!

            marycooch Mary Cooch added a comment -

            Removing the qa_test_required label as there is a test for this here MDLQA-5256 ready for the next cycle.

            marycooch Mary Cooch added a comment - - edited

            Removing docs_required as this is now documented here http://docs.moodle.org/25/en/Random_glossary_entry_block


              People

              • Votes:
                1 Vote for this issue
                Watchers:
                5 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved:
                  Fix Release Date:
                  14/May/13