Moodle
  1. Moodle
  2. MDL-35859

Notice when adding id numbers to calculation

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Trivial Trivial
    • Resolution: Fixed
    • Affects Version/s: 2.3.2, 2.3.6
    • Fix Version/s: 2.3.8, 2.4.5
    • Component/s: Gradebook
    • Labels:
    • Testing Instructions:

      Youll need a course with at least one existing grade item in it.

      Go to the gradebook to the categories and items screen. Add a new grade item (theres a button beneath the categories and items table).

      Once its created click the calculator icon in the new grade item's row.

      In the ID Numbers section enter some names for the existing grade items. For example, firstitem and otherassignment. Check that they save without error.

      Enter a formula using the ID numbers. for example =[[firstitem]]+[[otherassignment]]

      Check that it saves without error. It will complain about an invalid formula if it's not correct.

      Show
      Youll need a course with at least one existing grade item in it. Go to the gradebook to the categories and items screen. Add a new grade item (theres a button beneath the categories and items table). Once its created click the calculator icon in the new grade item's row. In the ID Numbers section enter some names for the existing grade items. For example, firstitem and otherassignment. Check that they save without error. Enter a formula using the ID numbers. for example =[ [firstitem] ]+[ [otherassignment] ] Check that it saves without error. It will complain about an invalid formula if it's not correct.
    • Affected Branches:
      MOODLE_23_STABLE
    • Fixed Branches:
      MOODLE_23_STABLE, MOODLE_24_STABLE

      Description

      When adding ID numbers to calculation, it throws a notice in developer mode.

      Invalid array parameter detected in required_param(): idnumbers
      line 605 of /lib/moodlelib.php: call to debugging()
      line 33 of /grade/edit/tree/calculation.php: call to optional_param()

        Gliffy Diagrams

          Issue Links

            Activity

            Tõnis Tartes added a comment -

            Adding fix

            Sol García added a comment -

            Hi, i have the same problem. Is there solution?

            Andrew Davis added a comment -

            The patch doesnt seem to exist so I have removed the patch label.

            Andrew Davis added a comment -

            Adding a fix that seems to do the trick. Putting this up for peer review then I'll backport the fix.

            Sol García added a comment -

            The problem is when I edit the resource after configuring the gradebook. That's when gradebook disappears the resource id.

            Adrian Greeve added a comment -

            Hello,

            This is a simple enough fix. Looking further at the code I see that we are using $idnumbers as an array so this should have been using optional_param_array().

            No problems found. Submit for integration when ready.

            Sol García added a comment -

            Hi Adrian
            I changed in grade/edit/tree/calculation.php the code: $idnumbers = optional_param('idnumbers', null, PARAM_RAW); by : $idnumbers = optional_param_array('idnumbers', null, PARAM_RAW);, but the problem wasn't resolve.
            Can you help me?
            Thanks

            Andrew Davis added a comment -

            Sol, I'm not sure what trouble you're having as this seems to resolve the issue for me. I've created 2.3 and 2.4 versions. Putting this up for integration.

            Adrian Greeve added a comment -

            Hello Sol,

            I think that perhaps your problem might be unrelated to this issue. This patch is to remove the notice that appears when adding id numbers to grade items in the calculated grade settings. If you could give a more detailed explanation as to what your problem is we can determine if we can help your here, or direct you to create a new issue.

            Thanks.

            Dan Poltawski added a comment -

            This issue was solved for master and 25 with MDL-39609, so this is just for 2.4 and 2.3 now.

            Dan Poltawski added a comment -

            Thanks, i've integrated to 23 and 24

            Rajesh Taneja added a comment -

            Thanks for fixing this Andrew,

            Works fine for me.

            Damyon Wiese added a comment -

            Thanks for your contribution! This issue has been reviewed, integrated, tested and now released to everyone.

            Closing as Fixed!


              People

              • Votes:
                0 Vote for this issue
                Watchers:
                6 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: