Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-35975

Forum search box fieldset missing legend

    XMLWordPrintable

    Details

      Description

      Issue
      Form labels - The fieldset used for the searchbox is missing a legend when viewing a forum or a discussion in a forum.

      Standard Level
      WCAG 2 1.1.1 (A) http://www.w3.org/TR/UNDERSTANDING-WCAG20/text-equiv-all.html

      Impact
      Moderate

      Example Link
      http://accessibility.mroomstest.net/mod/forum/discuss.php?d=1

      Test Steps

      1. Login as user0
      2. Navigate to algebra 101
      3. Navigate to a forum
      4. View the source code for the search box in the upper right.

        Attachments

        1. image-2020-04-13-02-12-53-228.png
          7 kB
          Michael Milette
        2. MDL-35975-clean.png
          153 kB
          Luca Bösch
        3. searchforumboost.png
          37 kB
          Marina Glancy
        4. searchforumclean.png
          40 kB
          Marina Glancy

          Issue Links

            Activity

              People

              Assignee:
              moodle.com moodle.com
              Reporter:
              jrh18 Jason Hardin
              Participants:
              Component watchers:
              Adrian Greeve, Jake Dallimore, Mathew May, Mihail Geshoski, Peter Dias, Andrew Nicols, Jun Pataleta, Michael Hawkins, Shamim Rezaie, Simey Lameze, Barbara Ramiro, Bas Brands
              Votes:
              1 Vote for this issue
              Watchers:
              7 Start watching this issue

                Dates

                Created:
                Updated: