Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-35986

Serenity theme on 2.3.3 - custom menu not showing up

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: 2.3.2
    • Fix Version/s: 2.3.3
    • Component/s: Themes
    • Labels:
    • Testing Instructions:

      pull up serenity theme while also setting the example (see the custom menu field) custom menu in 23. check that example custom menus work on the menu for this theme.

      bonus: check other themes as well.
      (this test is similar to MDL-35231 's test)

      Show
      pull up serenity theme while also setting the example (see the custom menu field) custom menu in 23. check that example custom menus work on the menu for this theme. bonus: check other themes as well. (this test is similar to MDL-35231 's test)
    • Affected Branches:
      MOODLE_23_STABLE
    • Fixed Branches:
      MOODLE_23_STABLE

      Description

      while testing MDL-35231 - i couldn't get the custom menu to work only for serenity theme (in integration repository on 23 branch which is) on 2.3.3

        Gliffy Diagrams

          Attachments

            Issue Links

              Activity

              lazydaisy Mary Evans added a comment -

              Here is what I see this morning, with patch and custommenu working

              lazydaisy Mary Evans added a comment -

              I have been doing some homework with this latest problem. It looks like there is a regression in 2.3 caused by some improvements done to Canvas theme MDL-34526 which were added to master(2.4)only.

              https://github.com/moodle/moodle/commit/6f7cb98f102746b83aa3d5e65ff1c6a746a0106f

              Add to this the changes made to Serenity theme in MDL-33110 which deleted layout files because I assumed that Serenity used the parent theme (Canvas) layout files, because theme/serenity/config.php had no $THEME->layouts, in much the same way Standard theme works with Base theme as parent.

              The upshot of this then is that Serenity needs Canvas layouts with block-regions and custom menu which currently Canvas does not posses in 2.3.

              Need to cherry-pick https://github.com/moodle/moodle/commit/6f7cb98f102746b83aa3d5e65ff1c6a746a0106f to MOODLE_23_STABLE - ASAP

              lazydaisy Mary Evans added a comment -

              Further to this, the reason I did not see the problem is that my version of Serenity had the layout files which I have put there recently while testing a docking problem reported in the forum.

              lazydaisy Mary Evans added a comment -

              Fixing this now...

              nebgor Aparup Banerjee added a comment -

              linking issue MDL-34526

              nebgor Aparup Banerjee added a comment -

              Thanks for some proper history there Mary!

              This is testing fine here in my integration so integrating..

              nebgor Aparup Banerjee added a comment -

              Thanks Mary, integrated into 23 only.

              rwijaya Rossiani Wijaya added a comment -

              Testing this in 2.3 only.

              It works as expected.

              Thank you

              Teat passed.

              nebgor Aparup Banerjee added a comment -

              Your issue has dug up some gold.
              It works great i've been told.
              Go forth, be brave, be bold.

              yay! "All your thoughts are belong to everyone."

              Thanks and ciao!


                People

                • Votes:
                  0 Vote for this issue
                  Watchers:
                  3 Start watching this issue

                  Dates

                  • Created:
                    Updated:
                    Resolved:
                    Fix Release Date:
                    12/Nov/12