Moodle
  1. Moodle
  2. MDL-36051

Quick Grading in Assignment module does not turn on in some circumstances

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 2.3.2
    • Fix Version/s: 2.3.3
    • Component/s: Assignment
    • Labels:
    • Testing Instructions:
      1. Go to course and create assignment (assign module)
        1. In assignment settings set "File submissions" to "No"
        2. Click "Save and display"
      2. Click "View/grade all submissions"
      3. Click "Quick grading"
        1. What should happen: Page reloads and you can now enter in grades using the quick grading UI
        2. What happens instead: Page does not reload and you get a js error "Uncaught TypeError: Cannot call method 'on' of null"
      Show
      Go to course and create assignment (assign module) In assignment settings set "File submissions" to "No" Click "Save and display" Click "View/grade all submissions" Click "Quick grading" What should happen: Page reloads and you can now enter in grades using the quick grading UI What happens instead: Page does not reload and you get a js error "Uncaught TypeError: Cannot call method 'on' of null"
    • Affected Branches:
      MOODLE_23_STABLE
    • Fixed Branches:
      MOODLE_23_STABLE
    • Pull from Repository:
    • Pull Master Branch:
    • Rank:
      44813

      Description

      With the new Assignment module there is no obvious way to turn on Quick Grading when looking at a list of students to be graded.

      When looking at a list of students to be graded, there is a "Quick grading" item with a check box at the bottom of the list of students (see attachment). Clicking on this check box would seem to be the obvious way to turn on Quick grading, but nothing happens.

      In order to turn on Quick grading a teacher has to:
      1) check the Quick grading check box
      2) then, select a number in the "Assignments per page" drop down menu - only then will Quick Grading be possible.

      To turn off Quick Grading, the reverse is necessary.

      This is very opaque and not intuitive.

      Solution:
      either activate Quick Grading a soon as the check box is elected, or have a [save setting] button to the right of the Quick Grading check box

        Issue Links

          Activity

          Damyon Wiese added a comment -

          Hi Peter,

          The clicking on the quickgrading checkbox should immediately refresh the page and enable/disable quick grading with no further action required (and it does for me). If this is not the case for you, there could be a javascript error on the page that is preventing this behaviour. Can you check the javascript console for errors after clicking on this checkbox? The javascript console is available by pressing F12 in firefox or IE9+.

          Regards, Damyon

          Peter Ruthven-Stuart added a comment -

          Hello Damyon,

          No errors appear in the javascript console when clicking on the quickgrading checkbox.

          However, try this:
          set up the Assignment so that:
          Online text = No
          File submissions = No
          Submission comments = No

          then click on the quickgrading checkbox - with me nothing happens.

          However, if I change
          Online text = YES

          then clicking on the quickgrading checkbox does immediately refresh the page.

          By the way, this happens on a Mac (10.7.5)

          • Firefox 16.01
          • Safari 6.01
            Windows XP
          • Firefox 15.01
          Michael de Raadt added a comment -

          I was able to replicate that problem following your steps.

          Rex Lorenzo added a comment -

          Just ran into the problem. The problem is because the code is assuming that the filter dropdown will be present. But that filter is only present when file submission is turned on. I will be submitting a patch very shortly.

          Rex Lorenzo added a comment -

          Damyon, can you please code review my patch? It is a simple check to see if the filter element/option is set.

          Damyon Wiese added a comment -

          Looks great Rex, thanks for the patch. There is a duplicate for this issue - but I will mark that one as the duplicate because this one has a patch.

          Dan Poltawski added a comment -

          Thanks Rex & Damyon, integrated to 23 and master.

          Ankit Agarwal added a comment -

          Works as described.
          Thanks

          Eloy Lafuente (stronk7) added a comment -

          Amazed. Inspired. Grateful. That’s how your generosity makes me feel.

          (not really)

          Closing, thanks!


            People

            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: