Details

    • Type: Task
    • Status: Closed
    • Priority: Minor
    • Resolution: Fixed
    • Affects Version/s: 2.4
    • Fix Version/s: 2.4
    • Component/s: Libraries
    • Labels:
    • Testing Instructions:

      see MDL-35515 for last testing instructions:

      usual YUI testing after new version import, open JS console and visit moodle pages that use YUI:

      • course page edit mode
      • navigation
      • file picker
      • imscp and scorm
      • user selection forms - groups, roles, cohorts, etc.
      • gradebook

      note: the dragging of file picker is a known unresolved regressions

      Show
      see MDL-35515 for last testing instructions: usual YUI testing after new version import, open JS console and visit moodle pages that use YUI: course page edit mode navigation file picker imscp and scorm user selection forms - groups, roles, cohorts, etc. gradebook note: the dragging of file picker is a known unresolved regressions
    • Affected Branches:
      MOODLE_24_STABLE
    • Fixed Branches:
      MOODLE_24_STABLE
    • Pull from Repository:
    • Pull Master Branch:
      w43_MDL-36145_m24_yui373

      Description

      just released, see http://www.yuiblog.com/blog/2012/10/17/yui-3-7-3-windows-8-apps-and-ie-10/
      the biggest change is support for new Windows which is imo important for moodle too.

        Gliffy Diagrams

          Attachments

            Issue Links

              Activity

              skodak Petr Skoda created issue -
              skodak Petr Skoda made changes -
              Field Original Value New Value
              Link This issue has a non-specific relationship to MDL-35616 [ MDL-35616 ]
              skodak Petr Skoda made changes -
              Link This issue has a non-specific relationship to MDL-35771 [ MDL-35771 ]
              skodak Petr Skoda made changes -
              Status Open [ 1 ] Waiting for integration review [ 10010 ]
              Pull Master Diff URL https://github.com/skodak/moodle/compare/master...w43_MDL-36145_m24_yui373
              Pull Master Branch w43_MDL-36145_m24_yui373
              Pull from Repository git://github.com/skodak/moodle.git
              Fix Version/s 2.4 [ 12255 ]
              Testing Instructions see MDL-35515 for last testing instructions:

              usual YUI testing after new version import, open JS console and visit moodle pages that use YUI:

              * course page edit mode
              * navigation
              * file picker
              * imscp and scorm
              * user selection forms - groups, roles, cohorts, etc.
              * gradebook

              note: the dragging of file picker is a known unresolved regressions
              phalacee Jason Fowler made changes -
              Labels triaged
              Affects Version/s DEV backlog [ 10464 ]
              phalacee Jason Fowler made changes -
              Fix Version/s DEV backlog [ 10464 ]
              Affects Version/s DEV backlog [ 10464 ]
              stronk7 Eloy Lafuente (stronk7) made changes -
              Currently in integration Yes [ 10041 ]
              skodak Petr Skoda made changes -
              Fix Version/s DEV backlog [ 10464 ]
              samhemelryk Sam Hemelryk made changes -
              Status Waiting for integration review [ 10010 ] Integration review in progress [ 10004 ]
              Integrator samhemelryk
              samhemelryk Sam Hemelryk added a comment -

              The summary of changes can be found here: https://github.com/yui/yui3/wiki/YUI-3.7.3-Change-History-Rollup
              It really looks like they have focused most of their effort for this release on win8 + IE10 and passing lint tests. Everything looks pretty safe, I did check out the changes to drag and drop, everything appears fully bc so should be no probs.
              I'll double check with the other integrators that there are no objections to this landing, certainly gets a +1 from me.

              Many thanks
              Sam

              nebgor Aparup Banerjee added a comment -

              yup, +1 here.

              for testing bc here we'd need some IE10 users (Jerome did mention moodle breaking totally for him for ie10 - adding him as watcher)

              samhemelryk Sam Hemelryk added a comment -

              This has now been integrated. Many thanks Petr.

              samhemelryk Sam Hemelryk made changes -
              Status Integration review in progress [ 10004 ] Waiting for testing [ 10005 ]
              dmonllao David Monllaó made changes -
              Tester markn86
              markn Mark Nelson made changes -
              Status Waiting for testing [ 10005 ] Testing in progress [ 10011 ]
              markn Mark Nelson made changes -
              Link This issue testing discovered MDL-36319 [ MDL-36319 ]
              poltawski Dan Poltawski added a comment -

              "for testing bc here we'd need some IE10 users" ?? IE10 only came out this week

              poltawski Dan Poltawski added a comment -

              Looks good in IE10

              poltawski Dan Poltawski made changes -
              Status Testing in progress [ 10011 ] Tested [ 10006 ]
              markn Mark Nelson made changes -
              Link This issue testing discovered MDL-36321 [ MDL-36321 ]
              poltawski Dan Poltawski added a comment -

              Hurray!

              You did it, congratulations! You have on Mojito credit to redeem after the release of Moodle 2.4

              poltawski Dan Poltawski made changes -
              Status Tested [ 10006 ] Closed [ 6 ]
              Resolution Fixed [ 1 ]
              Currently in integration Yes [ 10041 ]
              Integration date 01/Nov/12
              dobedobedoh Andrew Nicols made changes -
              Link This issue has been marked as being related by MDL-37125 [ MDL-37125 ]

                People

                • Votes:
                  0 Vote for this issue
                  Watchers:
                  4 Start watching this issue

                  Dates

                  • Created:
                    Updated:
                    Resolved:
                    Fix Release Date:
                    3/Dec/12