Moodle
  1. Moodle
  2. MDL-36192

File Submission with Internet Explorer (9 or 10) not loading--but loads fine in Firefox (16.01)

    Details

    • Type: Bug Bug
    • Status: Closed
    • Priority: Minor Minor
    • Resolution: Won't Fix
    • Affects Version/s: 2.3.2
    • Fix Version/s: None
    • Component/s: Assignment
    • Labels:
      None
    • Workaround:

      It is possible to add a header to force ie to not use compatibility mode. Moodle 2.4 uses a HTML5 doctype to force this, but for Moodle 2.3 it is possible to add the following to your Moodle config file.

      $CFG->additionalhtmlhead = '<meta http-equiv="X-UA-Compatible" content="IE=edge" />';
      

      Which will have the same effect.

      Show
      It is possible to add a header to force ie to not use compatibility mode. Moodle 2.4 uses a HTML5 doctype to force this, but for Moodle 2.3 it is possible to add the following to your Moodle config file. $CFG->additionalhtmlhead = '<meta http-equiv= "X-UA-Compatible" content= "IE=edge" />'; Which will have the same effect.
    • Affected Branches:
      MOODLE_23_STABLE
    • Rank:
      44970

      Description

      File Submission with Internet Explorer (9 and 10) were working fine in version 2.3.2 build 20120914; however, when we upgraded to version 2.3.2 build 20121018, we are no longer able to see the file submission options in this browser.

      At this point, all users with Internet Explorer 9 or 10 are unable to upload files to any assignment as both the ability to drag-and-drop file submissions and upload files button are missing/not loading (all they see is the spinning wheel where the file upload options should be).

        Issue Links

          Activity

          Ivan Serina added a comment - - edited

          Same thing happens to me.
          Moreover when I enable "turn editiong on" in IE (8 or 9 or 10)the lateral bars (navigation, setting, calendar, online users, etc.) loose their position.
          Setting the document compatibility mode to IE9 or IE8 the problem disappear but I cannot explain this procedure to all the users
          Regards

          Oliver Steffen added a comment -

          We have also upgraded to build 2.3.2 build 20121018 and are having the same problem. Students can see the add submission or edit my submission button but when they click on the button they see the spinning wheel. We also find that this works fine in firefox.

          Oliver Steffen added a comment -

          we have manged to find a work around for this problem by adding the following to our web.config file.

          <httpProtocol>
          <customHeaders>
          <add name="X-UA-Compatible" value="IE=Edge" />
          </customHeaders>
          </httpProtocol>

          This addition to web.config forces IE to load moodle pages with compatability mode turned off. By default IE turns on compatability mode for all intranet sites and since our moodle site uses the same domain as our network domain it is classed as an intranet and compatability mode is turned on.

          This helped me to understand and resolve the problem http://stackoverflow.com/questions/1014666/force-ie8-into-ie7-compatiblity-mode

          This worked for IIS but I'm not sure how to acomplish the same on other web platforms.

          Joseph Fulginiti added a comment -

          Like Oliver said, this is caused by ie compatibility mode. If the fix above is not an option, and your computers are on a domain, this can be fixed via group policy,

          To Clear the compatibility list, delete the following registry key:
          HKCU\Software\Microsoft\Internet Explorer\BrowserEmulation\ClearableListData\UserFilter

          To uncheck Display intranet sites in Compatibility view:
          In Group Policy set: Computer Configuration\Administrative Templates\Windows Components\Internet Explorer\Compatibility View\Turn On Internet Explorer Standards mode for local intranet. Set to enabled

          Ivan Serina added a comment -

          I have added the following lines to http.conf
          <<<
          LoadModule headers_module /usr/lib/apache2/modules/mod_headers.so

          <IfModule headers_module>
          Header set X-UA-Compatible: "IE=Edge" env=ie
          </IfModule>
          <<<
          Unfortunately when a teacher enable "turn editing on" the bug reappears.

          I can't understand why this bug is classified as "Minor".
          Regards
          Ivan

          Oliver Steffen added a comment -

          Although we have been able to get the file submission working by forcing compatability mode off we have now found that some of our scorm packages require compatability mode turned on to display correctly. So this is still an issue for us.

          Ivan Serina added a comment - - edited

          Unfortunately, the problem still persists on my computers also using the workaround proposed by Damyon Wiese.

          Regards
          Ivan Serina


            People

            • Votes:
              3 Vote for this issue
              Watchers:
              6 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: