Uploaded image for project: 'Moodle'
  1. Moodle
  2. MDL-36227

Requires on 'Plugin dependencies check' confusing.

    XMLWordPrintable

Details

    • Improvement
    • Status: Open
    • Minor
    • Resolution: Unresolved
    • 2.3.2, 2.4
    • DEV backlog
    • Administration
    • MOODLE_23_STABLE, MOODLE_24_STABLE

    Description

      The 'Requires' on the 'Plugin dependencies check' shows the version of Moodle which is a combination of the branching date and a release - http://docs.moodle.org/23/en/Moodle_version - however this can be a little obscure to users when installing and updating plugins. Therefore I consider it would be better if the release (as defined by the '$release' constant in version.php) was displayed instead. Then the user would know what date to move forward to, given that the 'Home->Site Administrations->Notifications' already displays this instead of the version.

      I have dealt with a few queries already from confused users as my course format requires a certain version.

      Attachments

        Issue Links

          Activity

            People

              moodle.com moodle.com
              gb2048 Gareth J Barnard
              Andrew Lyons, Huong Nguyen, Jun Pataleta, Michael Hawkins, Shamim Rezaie, Simey Lameze, Stevani Andolo
              Votes:
              0 Vote for this issue
              Watchers:
              4 Start watching this issue

              Dates

                Created:
                Updated: